Start a Conversation

Solved!

Go to Solution

1201

October 6th, 2022 04:00

Vxrail upgrade shows error status upgraded

Hello i'm trying to update vxrail from version 7.0.241 to the latest currently at writing this post 7.0.400 . since the upgrade is marked as critical so i'm trying to upload it via vcenter .

i'm getting the error :

Operation conflict with state. the requested action Download_And_Upload_To_Datastore conflict with the current state UPGRADED
i searched on the net and since in version 7.0 the database has been changed the procedure to change the value upgrade no longer works. according to this kb  https://www.dell.com/support/kbdoc/en-ed/000168419/dell-emc-vxrail-upgrade-fails-with-error
 
    • Open the mystic DB using the command below on the VxRail Manager VM: 
psql -U postgres mysticmanager;
  • Reset the upgrade status to HAS_NEWER by running the following command:
update virtual_appliance set upgrade_status='HAS_NEWER'where component_id='VXRAIL_SYSTEM';
  • Restart runjars and vmware-marvin services using the below commands 
systemctl restart vmware-marvin
systemctl restart runjars
 
so do someone have the procedure for new version 7.0
thanks for help
  •  

2 Posts

October 7th, 2022 02:00

Hello Thanks for your reply , i'm not a partner so i don't have access to that kb, i opened an SR ticket and one from support team corrected the issue , it was a false status caused by the last upgrade.

he simply curled the status none to the json file so to tell the vxrail that the status is not in the upgraded status : 

echo '{"state":"NONE","deployed_for_public_api":false}' > /var/lib/vmware-marvin/bundle_state.jso

Moderator

 • 

8.5K Posts

October 6th, 2022 10:00

Hi,

Thanks for your question. If you are a partner try the steps in this article. https://dell.to/3EnlXE8 If you are not you will need to call phone support.

 

Let us know if you have any additional questions.

No Events found!

Top