Start a Conversation

Solved!

Go to Solution

1 Rookie

 • 

7 Posts

1669

July 5th, 2022 06:00

How to configure Wyse ThinOS clients over to secure MQTT channel?

Could anyone possibly share some insights on how to configure Wyse ThinOS clients to talk with WMS over secure MQTT channel?

My test WMS has both the TCP ports 1883 (non-secure) and 8443 (secure) open but the ThinOS client shows it's talking only over non-secure 1883. So how to get the ThinOS clients by-default to choose the secure MQTT over the non-secure?

 

Thank you for your help.

1 Rookie

 • 

7 Posts

July 15th, 2022 05:00

I managed to get the secure MQTT working. Got a  tip from DELL WMS documentation and the solution were to enable local firewall on the WMS host server and block the incoming traffic to the non-secure port (TCP 1883 in my case). After that the ThinOS went automatically over to secure MQTT (TCP port 8443 in my case).

July 6th, 2022 02:00

Hello,
As far as I know, to use secure MQTT, you need to use Wyse Management Suite Pro version. In the Standard version, this functionality is not available.
Which version you are using Dell WMS Std or Pro?

July 6th, 2022 03:00

If you have the support it will be better to open a service ticket, I think Dell should know how to fix this. In our environment, we are using Dell WMS Std without secure MQTT capabilities.

1 Rookie

 • 

7 Posts

July 6th, 2022 03:00

We are using the Pro version and on the WMS server settings the secure MQTT is enabled and port 8443 is open as stated in OP.

5 Posts

November 30th, 2022 05:00

Hello, Thin client MQTT Server shows Idle status. We are using public cloud WMS.

Any hint.

Thanks.

No Events found!

Top