Start a Conversation

Solved!

Go to Solution

Closed

6 Posts

613

June 30th, 2023 02:00

Keyboard layout inverted in OS

Hello everyone,

I'm updated my 3040 wyse clients from 8.6_807 to Thinos 2303 (9.4.1141) with Citrix Workspace App 23.2.0.10.4.

Everything is working well execpt the keyboard layout. My clients are set to French language on both client and server. Unfortunatelly, the OS keyboard Layout is "ENG" (Anglais(Etats-Unis) Clavier Anglais (Etats-Unis). But when I type something, the keyboard is in AZERTY mode. If I switch to "FRA" and FRA keyboard (On windows), the keyboard is in QWERTY mode ...

I had no problem in V8.6_807, and only one language was displayed in Windows.

In WMS, the keyboard setting is set to "Client keyboard".

I apprecied if anyone has an idea.

Have a nice day.

 

 

1 Rookie

 • 

34 Posts

July 17th, 2023 05:00

Hi. 

In WMS try setting Specific Keyboard under Citrix Session Settings -> Keyboard Layout Mode and then under Global Session Settings -> Locale enter 0x040C (this should be the MS language code identifier for french France).

Another possible solution would be to use IgnoreRemoteKeyboardLayout registry setting. On the Citrix Servers under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout. Create a new DWORD (32bit) value IgnoreRemoteKeyboardLayout and set the value to 1 . You do  not need to reboot the server but just logoff and login again. After the client keyboard settings will be ignored and you can set your layout in the session.

Alex

6 Posts

July 17th, 2023 06:00

hello Alex,

 

Thank you for your answer.

 

I finaly manage to make it work.

I was rebooting the server trought Windows (Thinking that it would not erase my configuration like rebooting via the controler console...)

I used the IgnoreKeyBoardLayout registery key and also this two:

 

Unicode Keyboard Layout Mapping Feature
This feature is not enabled by default. To enable Unicode keyboard mapping between the non-Windows client and the VDA:
In the VDAs’ system registry, navigate to:
HKEY_LOCAL_MACHINE/SOFTWARE/Citrix
Create the following key:
HKEY_LOCAL_MACHINE/SOFTWARE/Citrix/CtxKlMap
In this key, create the DWORD entry EnableKlMap with a value of 1
The feature can be disabled by setting EnableKlMap to a value of 0
 
Unicode Keyboard Layout Mapping Compatible Mode
Setting the EnableKlMap to a value of 1 will hook a Windows API that reloads a new Unicode keyboard layout map when the user changes keyboard layout on the VDA side. Some published applications may not be able to be hooked, so in addition to enabling EnableKlMap, the feature can also be configured for compatibility mode.
In the VDAs’ system registry, navigate to:
HKEY_LOCAL_MACHINE/SOFTWARE/Citrix/CtxKlMap
In this key, create the DWORD entry DisableWindowHook with a value of 1
Compatibility mode can be disabled by setting DisableWindowHook to a value of 0

1 Rookie

 • 

34 Posts

July 17th, 2023 06:00

With IgnoreKeyBoardLayout you shouldn't need the other registry keys as this will completely disable/ignore the client settings. We use the WMS settting for all clients except clients with US International keyboard. For some reason ThinOS doesn't map US International properly and these users must work on a server with the IgnoreKeyBoardLayout registry entry. If possible use the WMS settings I suggested above as the IgnoreKeyBoardLayout will completely disable the support for client keyboard mapping and sometimes it is handy to have it (for example if  you use MacOS clients) as it will automatically switch to the local client layout.

1 Rookie

 • 

34 Posts

July 20th, 2023 01:00

Actually I suggested not using the registry key and setting Keyboard Layout Mode to "Specific Keyboard" in WMS and not "Use Client Settings" and under Global Session Settings in the Locale field enter the correct regional code. This is what we use and works. Here is a Screenshot of our WMS settings (please note that the regional code in the screensshot is for swiss german).

2023-07-20 10_52_18-Wyse Management Suite.jpg

6 Posts

July 20th, 2023 01:00

Unfortunately I tried without the two registery key above (with only "IgnoreKeyBoardLayout") and " Use client settings" in WMS and It doesn't worked

6 Posts

July 20th, 2023 02:00

My bad for the confusion. I'm gonna try this ASAP.

6 Posts

August 1st, 2023 02:00

Finally been able to test it. Had to set the registry key to 0 (deleted it the first time).

Everything works fine.

Thank you for your help.

No Events found!

Top