Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

55390

February 5th, 2018 20:00

XPS 13-9370, Keyboard skips button presses

remove

1 Message

December 6th, 2018 12:00

@DELL-Justin C Same issues exists on E6430 ATG from on-board keyboard. Does not existing with USB keyboard. All drivers are up to date. Running Win 7 Pro 64-bit. 

1 Message

December 19th, 2018 09:00

Problem persists with XPS 9370 with BIOS version 1.6.3

3 Posts

December 21st, 2018 02:00

Same for me. Latest BIOS patch and no difference..

6 Posts

December 23rd, 2018 00:00

Seems like they are just giving me the run round after 2 failed attempts to fix the issue. Guess i'm now stuck waiting for another bios update and a useless laptop.

3 Posts

January 2nd, 2019 19:00

Same exact problem with the Dell XPS 9530 - I thought I went crazy and had some weird hardware defect until I read this thread. 100% matching of symptoms.. Dell, when will you start fixing this ?!

1 Message

January 6th, 2019 23:00

Hello everyone, I have Dell 7573 core i5. The problem is the Keyboard. Watch the video https://youtu.be/pZ_Um1rPEy4

January 8th, 2019 11:00

Exact same issue with my Dell XPS 13 (9370) skipping and duplicating keys. Only one in five keys presses register on average, and it random and make the laptop unusable. Problem is present on  BIOS 1.5.1 and 1.6.3 but keyboard works perfectly on 1.2.0 (Haven't tried others) so I'm stuck on that until a fix is found.

6 Posts

January 17th, 2019 20:00

So after a few tech visits to replace various parts of the laptop. Dell agreed to replace my laptop yesterday. New one turned up today. Everything seems to be working perfectly, though the dell assistant is asking me to update to the current 1.6.3 bios from 1.51. Not sure if I should risk it after the drama caused me from updating bios in the first place.

1 Message

March 26th, 2019 07:00

I had no problem on my XPS 13 9360, *until* I upgraded the BIOS to 2.10.0.

Since upgrading, I have the problem on external USB keyboard, if connected through the WD15 docking station. USB-C. 

The external keyboard seems ok if connected directly to the laptops USB.

 

1 Message

March 28th, 2019 15:00

Hi all,

I'm also having the same issue re my brand new Dell XPS is failing to register all my key strokes - absolutely frustrating!

I've tried some of the fixes but still not fixed - have Dell released a fix as yet?

Or have they even confirmed there is a problem?

66 Posts

June 25th, 2019 14:00

I have a 9350 and I started noticing that the skipped key problem is getting worse. I think its consistent about which keys are having the problem and I find that if I type with stronger key presses (which means longer as well?) that it skips less.

It's starting to become a big problem. It's bad enough I started looking for a solution. I'm on 1.9.0 bios and will upgrade to 1.10.1.

I'm a touch typist and its starting to drive me crazy. I'll try booting into windows 10 and other tricks to see if that's causes issues but it does appear that the problem is slightly worse when I have a USB-C non-powered device plugged in. It is still present even with the USB-C non-powered device..

6 Posts

July 25th, 2019 07:00

I'm tired of my XPS and of the many problem that seem never ending Now it's the keyboard Dell, do you know how important is typing for me? I'm a Linux sysadmin

1 Message

December 17th, 2019 21:00

I am using a Dell XPS 13 9360, and it seems I have a similar keyboard issue (>50% of key presses skipping). This issue ONLY occurs when I power the PC using a USB-C charging adapter. This adapter was working fine until recently (~1 month), and though I updated to the 2.12.0 BIOS, the problem remains. This thread is the only thing I've found on any similar topic. Is anyone seeing this issue as well? What might the fix be?

No Events found!

Top