Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

55390

February 5th, 2018 20:00

XPS 13-9370, Keyboard skips button presses

remove

February 16th, 2018 09:00

remove

5 Posts

February 17th, 2018 14:00



@perpetoom wrote:

I would recommend to take a look at Microsoft or Apple notebooks (Yeah, I know that there are also not absolutely problems free) or just wait a couple of months for Dell to fix/enhance manufacturing, quality check processes and software related problems.

I went to try Surface Laptop's keyboard and I must say it's the most solid laptop keyboard that I've come across besides that from Thinkpad. But it somehow doesn't have Thunderbolt 3. The old Macbook Pro was almost perfect in every aspect but Apple really messed up with the new MBP. The keyboard feels bad (though of course it still doesn't have this ridiculous problem of XPS 9370), touchbar, and to get a good 4-core processor one will have to go with the heavy 15'' model. I just ordered the newest Thinkpad X1 Carbon 6th generation. Hopefully I'll be satisfied with that device instead. The price premium compared with XPS 9370 is such a pain though.

81 Posts

February 22nd, 2018 03:00

@SoccerChamp42 wrote:

You can press down two keys at once, both register, then quickly do it a second time and both always register again? If someone is not a fast typer that seems to be the easiest way to test it.

For sure I'm not that fast as you in regular typing but I tried experiment form first post with "hahaha" phrase without an issue. Even sliding finger fast through letters ie. "k", "m", " " one by one produces proper output (km km km ...). Pressing two or more keys (characters while typing, not a key-combo) at once and expect predictable result would be not a good idea since some kind of letter order in every word of is desired :) Anyway I've tried pressing "p" and "o" at once three times gives on my Dell 6 character output with: 3x "o" and 3x "p".

Still, it may be not as fast you expected so just saying that i did not observe this issue in my model but of course it can be discovered when pro-typer would be using it. Maybe touch-screen feature decreases possible input rate (my device is non-touch)?

2 Posts

February 22nd, 2018 16:00

Thanks for posting, I've had the same problem with my 9360 and it's been driving me crazy trying to figure out what's causing it.

In my case, I have  two other symptoms:

  • The repeated letter is inputted, but it lags by an additional character. For example: meter is input as metre, or Japan as Japna.
  • The repeated letter is omitted in words where it appears consecutively. For example: common is input as comon, or happen as hapen.

 

My observations:

  • When I spot a mis-type (lag or omission) and immediately go back and rewrite, the word or sentence gets input correctly the second time around.
  • The mis-types occur at random times (it'll lag or omit for one word, but not for others that have similar character repetition), but generally seem to occur most often when I suddenly start writing a large amount of text after a long period of little or no typing -- almost as though the keyboard (driver?) has some buffering problem when there is a sudden "burst" of keyboard input.

Since I write code, this is especially annoying as a program will fail for no particular reason, until I go back and check my code and find that a repeated letter in a variable or function name is sitting in the wrong place, while every other time that I've typed the same name has been input correctly.

I've worked on Thinkpads, Vaios, Surfaces, Macbooks, etc, and the XPS is the first laptop that has this problem. It's a shame too, because it's basically the only Windows laptop on the market that combines i7, 16GB, full-size SD slot, USB-C/TB3, and high-DPI wide-gamut display in an ultraportable formfactor.

I'm planning on keeping my 9360 despite this -- the other features are essential for me, the mis-typing occurs just rarely enough that it isn't intolerable, and I can circumvent this issue with an external keyboard. But for anyone that types a lot, I'd strongly recommend considering other options (Thinkpad X series, Surface Book/Pro, Razer Stealth)

2 Posts

March 5th, 2018 13:00

I have the exact same problem on my XPS (9370). I hope Dell can resolve this quickly.

10 Posts

March 6th, 2018 07:00

I've got the same exact problem. First thought it was my and did about 200 typing tests and glad I found this post. I'm not going insane.

The tests I did clearly showed the order of letters often are incorrect, resulting in a lot of correcting with backspace, which squeaks very loudly since I got it out of the box yesterday.

Edit:
Running the 9370, i7 8550u, 16g, 512gb, uhd, ubuntu 16 with latest updates.
Will try another linux distro later.

Edit #2:
cross referencing to another thread with same issue.
https://www.dell.com/community/Linux-Developer-Systems/XPS-13-9370-fresh-install-Keyboard-response/m-p/5760558

Please Dell, look into these issues.

3 Posts

March 10th, 2018 19:00

I have this problem too. It's really frustrating and results in typos every few minutes.

3 Posts

March 11th, 2018 00:00

I have a Dell XPS 9370. I've discovered a sure way to test whether your keyboard is affected.

  1. Open Notepad.
  2. Repeatedly type any two letters on the keyboard alternatingly at a very rapid speed, like "abababab...".
  3. If you observe any repeated letters in the Notepad window, your keyboard is skipping letters.

This is a screenshot with the errors highlighted: https://imgur.com/a/1m4D6 

1 Message

March 18th, 2018 22:00

I'm having a similar issue, but instead of seeing missed button keystrokes, I'm seeing extra keystrokes - notably keystrokes like ctrl / alt showing so that inadvertent hot-key combinations are being invoked.

Ubuntu 17.10

One of the things I'd suggest trying is to run the following:

 

sudo apt-get instal evtest
sudo evtest

 

This will let you see a detailed screen debugging the data being received from the device. In my case, this is helpful because as I type this my console spits out a detailed log of the keystrokes that I am typing.

4 Operator

 • 

783 Posts

March 22nd, 2018 15:00

@Community,

I'm pleased to inform you that I have replicated the key skip symptom here in house on a random 9370 I had around here. 

Replication conditions:

-XPS 13 9370

-Windows 10

-All Dell updates installed using Dell Command Update

-BIOS 1.2.1

I'm now driving the issue through internal channels in order to obtain a solution. 

I'll get back as soon as I know more.

10 Posts

March 23rd, 2018 06:00

I'm glad you were able to reproduce the issue.
Hopefully there will be a fix. Thanks!

4 Posts

April 2nd, 2018 14:00

Just wanted to add the XPS13 9365 2in1 to the list of affected systems. Mine exhibits the same character skipping as the OP reported. The two models on display at the local Best Buy exhibit the same behavior as well, so I don't think it is faulty hardware.

April 3rd, 2018 06:00

I understand that it's only been about a week but I have to ask: is there an update on this? I purchased this laptop last night and immediately ran into this issue. I need to decide if I should go ahead and get a refund.

Thanks.

2 Posts

April 3rd, 2018 07:00

Have you tried updating the driver, if the issue is not solved the do a quick run for hardware diagnosis. You can follow this to do these 2 steps.

1.Restart the computer. As the computer boots, press < F12 > when the Dell Splash Screen appears.

2. When the Boot menu appears, highlight the Boot to Utility Partition option, or the Diagnostics option and then press < Enter > to start the 32-bit/64-Bit Dell Diagnostics.

If the issue is not yet solved then you should probably run to the dell service center or call dell support for home service. 

1 Message

April 3rd, 2018 10:00

+1 for same issue here.  (Actually just happened as I was typing the word "here" and instead it registered "her")

Anyone gotten any other replies from Dell?  Latest bios, drivers, etc installed.  Diagnostics run etc.  Win10.

Adam

 

No Events found!

Top