Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

107911

January 24th, 2018 18:00

XPS 13-9370, mouse cursor lagging and stuttering

Having an issue with my new XPS 9370. Using the touchpad (haven't tried using a mouse with it at all), the mouse cursor sometimes stutters/freezes for a second then keeps going. Happens quite a lot actually. Sometimes it actually stutters multiple times in one swipe on the touchpad but other times it works fine..any ideas on what to do? I don't see any specific touchpad options in windows settings or anything either.. Thanks

4 Posts

February 24th, 2018 20:00

Experiencing the same problem.  Got the problem pretty right away after receiving the laptop and rebooting it for a few times.  In my case the touchpad stuttering issue even goes into full system freeze some times. Once i reset the laptop all is well though.  Seems like weird random issue.

81 Posts

February 25th, 2018 05:00

Yeah, restart sometimes help but issue will probably come back sooner or later. Another quick (since it keeps your running apps untouched) & temporary workaround is pressing power button to suspend the device, wait 1-3 seconds and turning it back again. Problem is also more likely to happen when running  on AC rather than battery (at least that was the case two weeks ago; now I'm mostly using it with power cord attached).

It's quite pathetic to own a up-to-date premium notebook which constantly freezes (totally or just for seconds time by time) on such high performance situations like displaying Windows wallpaper/desktop...

 

NOTE FOR TESTERS: If you're trying to find a solution to this issue by updating bios/driver or adjusting/disabling some settings/features - always turn your device off before performing a check since is more common that problem will occur after "fresh start" rather on restart.

4 Posts

February 25th, 2018 15:00

Yeah I completely agree and I am astounded that the product was launched with this kind of problem. Pretty major if you ask me and something that must have turned up during testing for sure.  There is just no way they don't know about his problem when it is such a glaring issue.

Either way I really hope this not a hardware issue.  A real problem for what is otherwise an amazing laptop.

February 26th, 2018 02:00

Have someone tried a clean windows install?

February 26th, 2018 03:00

I also can confirm that the issue is still present with current BIOS update and with Intel driver directly from Intel homepage.

What helps me in a current freeze situation is to get into sleep mode with fn key combination and login back again. 

However, this issue is really annoying and needs to be fixed. Thinking of returning as well. 

Shrot question, does someone of you also experience the fans kicking in while charging right from the start, even under idle and fans just stop when the battery is about 85% charged?

4 Posts

February 26th, 2018 11:00

New XPS 9370 owner here. Also suffering from the freezing and mouse stutter. This is a brand new 4k 9370, received today so clean install and fully patched. I've only noticed this happening when coming out of sleep mode (closing the lid) and it doesn't clear up until a full reboot is performed. It appears to be the system freezing as it doesn't just affect using the track pad, it also affects typing. I'm not using an external mouse. Very frustrating.

Has anyone got a ticket open with Dell for this?

21 Posts

February 27th, 2018 09:00

I’m also getting this every now and then, using latest 1.2 bios. If I close Chrome browser it seems to clear up.

February 27th, 2018 10:00

I've tried everything as well and with customer support as well. They can't figure it out either. They are sending me a replacement device.

If you need any momentary relief, rather than restarting, pushing the power button to quickly put the machine to sleep and logging back in with the finger print scanner works the best.

Things I did

- Update video card

- Update wifi card

- Upadte bios and reinstalling

- Manually went into websites for each manufactured parts and installed the latest drivers

- Ran stress test

- Ran Diagnosis

- Uninstalled Dell Support Apss (some said these caused the lag)

All failed...

1 Message

February 27th, 2018 11:00

Auch, this smells like a hardware error... could anyone with a replacement device let us know if it is resolved? Maybe it's a rev1 error :(

February 27th, 2018 12:00

Not entirely sure, as soon as they confirmed that nothing was helping, they offered me to replace it, all they confirmed was that I was the purchaser by some serial number on the charging brick. 

They also confirmed that they are going to send it a brand new, not a refurbished. 

So if your system is stuttering with no solution, might as well, just start up a chat and just tell them, that you have tried everything including a window reinstallation, and they will offer you to replace it.

I am not sure what are the terms for the timeframe for this, but I think I did get a hold of them within a week of usage.

February 27th, 2018 12:00

Yes please let us know about the outcome. Are you still in the 14 day recall period or is this a warranty case?

February 27th, 2018 12:00

Ok thanks. Please let us know if your new device faces the same issue. Thanks in advance.

4 Posts

February 28th, 2018 10:00

Feels more like an OS or driver issue to me. Booting from cold I do not see this problem. It's only after coming out of sleep or hibernate mode. Still disappointing fellow customers are not seeing success through the support team. I hope Dell are taking this seriously. I don't want to have to send it back because if it is a software issue, it will only continue to happen.

21 Posts

March 2nd, 2018 18:00

Weirdly I’m not having any issues lately even though I haven’t updated or done anything thing differently.

March 2nd, 2018 18:00

So, I got the new system today and I am using right now. For now I am not having any issues, it might have been a bad device with bad hardware. When I got he first system, the moment I turned on the machine for the first time I started to have issues. Will keep you updated, but so far I have used the system for about 1 hour with no issues, migrated all of my files, did system (dell required) required udpates including bios, and so far so good. Will play with it a few more days and will let you know. At his point I don't plan to go out my way and find the latest drivers for different parts, will stick to what dell app recommends. 

No Events found!

Top