Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

107908

January 24th, 2018 18:00

XPS 13-9370, mouse cursor lagging and stuttering

Having an issue with my new XPS 9370. Using the touchpad (haven't tried using a mouse with it at all), the mouse cursor sometimes stutters/freezes for a second then keeps going. Happens quite a lot actually. Sometimes it actually stutters multiple times in one swipe on the touchpad but other times it works fine..any ideas on what to do? I don't see any specific touchpad options in windows settings or anything either.. Thanks

4 Posts

March 6th, 2018 11:00

Early days but the panel refresh setting appears to be helping. I've also logged this with Dell who've linked me to a newer 1.2.1 bios version which I'm trying.

March 6th, 2018 11:00

I checked my settings and the Panel Refresh is on. So that isn't affecting my system at this time. I did not have a single stutter and it is day 5. 

March 6th, 2018 11:00

Nothing helps (Sppedstep, C-State, Intel Panel Self Refresh and even the latest BIOS1.2.1). The only logical solution seens to ask for a replacement. This must be something related to a defective production batch.

March 7th, 2018 13:00

To give you all an update. Dell is switching my XPS. But since for at least some days I am stuck with this one I have been doing some research and found a solution that has gone through a work day without issues (as always ask The Samsung if any of these alternatives are being shipped as default by Dell).

I have the following changes applied: BIOS 1.2.1:

  1. C-States is DISABLED;
  2. Both Virtualization support (Virtualization and VT for Direct I/O) are DISABLED

On Windows 10 under Intel Graphic Settings: Self Refresh and Gamming Battery Life are both DISABLED.

One might try different combinations to get to the ROOT issue (or combination). I personally will keep these setting not only because the machine is running flawless but also because it is a personal preference it makes the machine faster and safer (Virtualization does pose some risks).

March 9th, 2018 18:00

So I am into day 7 besides the killer wifi which looses connection from waking up (I have updated the latest driver, so I am crossing my finger on this), everything is running smooth. To verify, everything is on by default, c-state, and the other virtual settings are all on. Even the Video power settings. If this is a solution for some of you so be it, but my take is that we shouldn't be looking for solutions by sacrificing optimal settings for a brand new computer. 

Please get a new replacement while you can, even if you solve the issue, there will be an uneasiness in the back of your mind. I am very sure there was an issue with the first batch of the units.  Best of luck everyone. This will be my last post.

81 Posts

March 11th, 2018 06:00

@DanielBMLago  :: Sorry to hear that your problem is still present in your device. You can temporary switch to Micorosoft Basic Display Adapter to check whether problem is caused by the Intel GPU software or some other part of the system (Device Manager -> Display adapters [Intel] -> Update driver -> Browse My computer for driver software -> select Microsoft Basic Display Adapter)

Since - as you pointed out - more than this device is affected with "Panel self-refresh" problem it's at least more probable that it will be resolved by Intel.

 

@The Samsung  :: Check following topic, maybe it will help with your WiFi problems.

March 12th, 2018 10:00

Dear @perpetoom actually I do not face any issues with the XPS. I gradually restored the default BIOS 1.2.1 settings and confirmed that Intel SPR is the one to blame. So, while waiting for the replacement XPS (following the advice given by @The Samsung) to arrive will be using this one with Intel SPR DISABLED. Weird to see it does not affect all XPS... Maybe i7 related (since mine is UHD and yours is FHD).

 

March 16th, 2018 09:00

now i just toggled back (enabled) the panel self refresh and looks good. im not sure why

3 Posts

March 18th, 2018 12:00

Thanks, disabling C-state in the bios fixed the touchpad issue for me. I'm still going to exchange my 9370 for a new one though.

4 Posts

March 18th, 2018 18:00

I have also been in touch with Dell, Dell Japan, about this and so far haven't really gotten any answer except for the auto response please re-install everything. Which I did and didn't solve a **bleep** thing. In fact for some reason it made the problem even worse with lock ups pretty much any session I use the laptop.

That said I can also confirm that the Panel refresh setting seems to be the cause of the problem. In my case at least.  Have disabled it a few days ago and haven't had a lock up since.  Not sure how this will improve battery life though  which, maybe it is me, is quite disappointing.  Getting 5 or 6 hours out of it already feels like a challenge.

Really thinking about returning or not because I also ran Ubuntu on it and there I have zero problems. That makes me wonder if it really has nothing to do with the hardware and is indeed just a software issue.

March 19th, 2018 18:00

this solves my problem by going on intel support site graphics version 23.20.16.4973

i downloaded the zip not the exe. but first uninstall the driver you have restart then install from device manager

1 Message

March 23rd, 2018 01:00

Got my xps 13 9370 today, same problems here...It freezes! Sometimes its a complete freeze, sometimes its just a semi-freeze, tried everything. Really disappointing.

April 2nd, 2018 09:00

I have the XPS 9370 Developer Edition i7 4K. I started off briefly with the build in Ubuntu 16.04 but after freezing issues (along with several good reasons to try) I moved to Ubuntu 18.04 Beta. Freezing still happens an no mods seem to have stopped it yet. Battery life is terrible also. I just moved to the new BIOS but didn't get to test it fully because my laptop bag and charger was stolen from my car when thieves smashed my windows. I have a new one coming this week and will test it out more.

One other things that I feel I need to mention based on some other reviews is that I also use Chrome. On more than one device I recently started experiencing higher than normal idle CPU usage in Chrome. I recently improved that by one little tweak on the device I am using while waiting on my computer... Disabled Hardware Acceleration in Chrome settings. Chrome CPU usage dropped both directly on the Macbook Pro and the Ubuntu Virtual Machine.

Maybe this will boost my XPS battery life??? My 2015 Chromebook Pixel with Ubuntu on it happens to run give me smoother performance, no freezing, and 8-10 hours of battery life.

April 9th, 2018 23:00

Best way might be to boot into Linux Ubuntu 17.10 using a live USB and install the Linux 4.16 mainline kernel. If it works properly then, you have a Windows issue. Otherwise, exchange the laptop for a new one because it must be faulty. For me, the touchpad works fine in both Windows and Linux.

April 9th, 2018 23:00

Sounds like one of two things:

1) You received lemons

2) You stuffed something up with the software. Did any of you clean-install Windows?

In the past I have found some Dell drivers to be very particular about the way they are installed, for example getting the audio to work without MaxxAudio hammering my CPU in the background with the Dell 9365. Sometimes you have to manually feed it the drivers extracted from the package without actually installing it. Other times Windows Update drivers work better.

Either way, I have the Dell XPS B520151AU and no problems whatsoever except for the large amount of crapware that came installed like Dell SupportAssist, and their BIOS bugs / ACPI Linux errors which seem to persist with every model.

No Events found!

Top