Start a Conversation

Solved!

Go to Solution

Closed

21 Posts

48097

June 17th, 2019 10:00

XPS 15-9570, TB16, USB Type-C, no longer charging

Heya,

Notebook is about 3 months old, my TB16 dock worked fine since day one but suddenly as of friday a week ago charging no longer works via the TB16 Dock.

  • I am running Linux with an option to dual boot into windows.
  • Windows behaves the same however
  • Same thing happens when in BIOS and just watching the Battery screen
  • BIOS will report plugged in and charging but percentage goes down.
  • Dock is sometimes detected as 60W (in Bios) first but then switches to 130W quickly - indicates as charging but percentage goes down.
  • Tried co-workers TB16 Dock - same thing
  • Works fine via barrel plug

What I tried

  • Disconnecting the dock for a while
  • Booting with/without dock attached
  • BIOS battery settings (standard/adaptive/quick charge on/off)
  • Holding Dock button for a minute while disconnected from power and notebook
  • Checking the plug on the power brick of the docking station - removing and replugging it while dock was running and while it wasn't

As I am running linux by default I am sure that on the day it stopped working I did not do any bios/driver whatever updates.

As it's also not working in Bios it should be OS/driver agnostic.

Any idea what's wrong or what I could do?

The dock works normally apart from that - usb devices and display link monitor are working fine.

 

21 Posts

August 20th, 2019 08:00

@cornike Thank you for the input!

I however don't believe that is has anything todo with the docking station unless a newer xps 15 bios update requires the MST2 change maybe.

As mentioned in this thread the same behaviour can be seen on 3 other docks, where one is brand new and running an old firmware. All of these docks do not work with mine but work fine with my co-workers xps 15.

1 Message

August 20th, 2019 15:00

Thank you for this thread. We are experiencing the same issue with one of our XPS 15 9570 laptops. The problem started recently. We have tried the computer connected to the user's home WD15 dock, their office WD15 dock, and a new WD19 we purchased in troubleshooting. All three docks have the 180W AC adapter.

The problem is the same as described here. The notebook won't charge when connected to the dock alone; add the included XPS AC adapter, and it still won't charge. You have to remove the AC barrel charger, remove the dock, and then plug in the XPS AC barrel first to start charging. Then, if you want to use the dock's other features, you have to plug it afterwards.

2 Posts

August 21st, 2019 01:00

Seems the issue is hardware not bios/software etc.

There is a discussion on another forum (https://www.reddit.com/r/Dell/comments/co842t/xps_9570_burned_chip_does_not_charge_with_usbc/) where folk have opened up the case and found a burnt out chip...

21 Posts

August 21st, 2019 02:00

@Wallisp thank you - that explains a lot. I will check if this is also the case on mine but I'd suspect so

9 Posts

August 22nd, 2019 10:00

My XPS15 is still under warranty, I am a bit reluctant to open it and check the various components. Is there any other way to check that the USB-C charging system inside the XPS 15 is working OK ? Thanks to all for your help.

August 22nd, 2019 18:00

I opened up my Precision 5530 and yup, the little chip is fried. The shield over the chip that I had to remove to take a peek also has a burn mark on it.

Mystery solved for me at least.

1 Message

August 23rd, 2019 08:00

I have a Precision 5530 too with the same issue of "discharging" via USB C.

I didn't open it yet (it's a company notebook) but I'm assuming the chip may be burnt as well as I noticed the area getting very hot a few days before the issue started to appear.

1 Message

August 26th, 2019 09:00

I just checked my Precision 5530 and yup.  Burnt chip. Time to call Dell.

9 Posts

August 28th, 2019 23:00

Aptica, did you get any feedback from the backend team after escalation ?

Gh0stface, did you open your XPS ? Is the chip burnt ?

2 Posts

August 29th, 2019 03:00

As I have warranty on my XPS was finally able to get Dell to schedule a tech to replace mother board. This fixed the problem. 

August 29th, 2019 11:00

Just got my motherboard replaced today. Fixed it.

9 Posts

September 3rd, 2019 08:00

I am still in contact with Dell France. A last test to perform in the next days with another XPS, and if we confirm the XPS is faulty, then the motherboard will be replaced (it seemed it was not a surprise for the tech I had on the phone).

9 Posts

September 3rd, 2019 08:00

Hello,

For those who had a tech change the motherboard, did you get any information on whether this new motherboard has a component that will not fail?

Any word from Dell about this issue that seems repetitive? Is the new component more durable?

September 3rd, 2019 11:00

The tech that worked on my laptop said he has seen same or similar issues across many brands and models that have a USB-C dock. His theory is that the dock cable end is too big for a USB-C port. Failures may be coming from movement of the cable and / or stress on the port.

 

9 Posts

September 4th, 2019 06:00

Just finished my 5 week dance on this.  Laptop sent in, tech notes said "Logic board replaced".  Works again.

 

Piece of advice, if it worked before and no longer does, start the service claim immediately.  Don't waste hours and weeks of your life with the "driver update/support session" dance...

No Events found!

Top