I am trying to destroy the Celera Network Server and Reinstall. Before reinstalling the Celera Server, I am executing the following commands in order.
./clariion_mgmt -stop
unset NAS_DB
/sbin/service nas stop
./nas_raid -n ../bin/navicli -a x.x.x.x -b y.y.y.y -s cleanup
The fourth command which is supposed to destroy LUN and raidgroup fails with the below error. How do I resolve this error?
[root@EMC setup_backend]# ./nas_raid -n ../bin/navicli -a x.x.x.x -b y.y.y.y -s cleanup
Log will be created in the current directory
System x.x.x.x is up
System y.y.y.y is up
!!! WARNING !!!
The CLARiiON array connected to this Celerra control station
contains an existing configuration. "Celerra_emcnas_i0"
This could include user data.
If you continue by selecting 'y' to cleanup the system at the
next prompt all existing CLARiiON configuration for Celerra_emcnas_i0 will be
destroyed and the system will have to be reinstalled.
Proceed with caution!
!!! WARNING !!!
Do you want to clean up the system [yes or no]?: yes
Cleaning Storage Group "Celerra_emcnas_i0"
Removing LUN ........
Removing diskgroup .
Removing initiators ....
Removing storage group "Celerra_emcnas_i0"
Thank You Rainer. How can I resolve the below error.
[root@EMC-ATT sbin]# ./setup_clariion -init
Found CLARIION(s) CK200074500109
Setup CLARiiON CK200074500109 storage device... The IP address you specified for SPB x.x.x.77 doesn't match addresses x.x.x.y got by gethostbyname. Please correct one of them.
Failed
Setup of CLARiiON CK200074500109 storage device not completed.
it means that the information about the IP adresses of the builtin Clariion is inconsistent.
It needs to be the same in DNS, /etc/hosts and /nas/site/cshosts as well as some internal databases that you cant edit directly.
Either it was installed incorrectly or someone tried to change IP adresses and didnt realize that there are other commands that need to be done to refresh the internal config databases.
PLEASE contact EMC customer service and let them help. Just tell them to look at Primus emc175031
The fix could be more complicated and really depends on your specific setup
If you did it just for that reason than it was overkill.
You could have just removed the second 4+1R5 and the extra hot spares (after making sure they are no longer in use by any file systems or checkpoints), unbound the LUNs and created the new 8+1R5
The only reason to re-install would be if you need to change that first 4+1R5 to be changed where the DART OS is located - which isnt supported anyway.
Yes, I did use CSA. The reason for reinstallation was I wanted to reset the RAID group as ATA_RAID5 4+1 HS_8+1 which was initially configures as ATA_RAID5 4+1 HS 4+1 HS HS HS HS. Is it always necesary to reinstall the NAS software to reset the RAID?
I tried to Unbind the LUN and destroy the second RAID using Navisphere manager but it was giving me the following error. Navisphere: Local Domain->CX310->Storage Groups->Celerra_emcnas_i0->LUNS->Right Click on LUN 19->Unbind LUN "Contained Within a Storage Group"
When I execute Navicli Unbind command I get the below error. [root@EMCMGR sbin]# ./naviseccli -h spa unbind 6 7 8 9 10 -o Security file not found. Already removed or check -secfilepath option.
When I try to remove the raid group I get the following error. [root@EMCMGR sbin]# ./navicli -h spa removerg 8 Error: removerg command failed This RAIDGroup has LUNS in it. Unbind them and run removerg again.
I will keep your suggestions in my mind for future use.
Hello, The error is becasue you didnt removed the LUN from the SG before trying to unbind. remeber that before trying to unbind a LUN you must removed from the storage group first then unbind the LUN from the RAID group.
yeah i know that you already solved your problem since this post is from feb.
Rainer_EMC
6 Operator
•
8645 Posts
698
0
Posted February 16th, 2008 11:00
please contact EMC customer service - your local customer engineer or NAS specialist should be able to help you out.
Ask them to look at Primus emc163849 and releated.
I assume you know that DART currently is not customer installable