
Attachment uploads are currently disabled. This is a temporary situation and will resume as normal in the coming days.
Solved!
Go to SolutionB
briantrotter
15 Posts
0
13909
February 28th, 2007 08:00
Problems trying to move data from Windows to NAS using Robocopy or Emcopy
We are trying to do a cutover from a Windows File Server to the Celerra NAS CIFS server.
In preperation, I am trying to use Robocopy or Emcopy to copy the data from our Windows File Server to the NAS.
I am trying to copy several Terabytes of data. Most copies will usually copy around 75% of the data, but there is always a group of data that will not move. It seems as though it is data with NTFS permission oddities, but even after correcting them, I often still cannot copy the data.
Here is a sample entry that is created from Robocopy:
2007/02/26 16:20:23 ERROR 1307 (0x0000051B) Copying NTFS Security to Destination Directory d:\departments\administration\Allen\
This security ID may not be assigned as the owner of this object.
2007/02/27 15:10:09 ERROR 1308 (0x0000051C) Copying NTFS Security to Destination Directory d:\departments\administration\year end\2001\
This security ID may not be assigned as the primary group of an object.
Here is a sample entry that is created from Emcopy:
Fixing security of z:\administration\Shortcut to Premium Summary Data.lnk
z:\administration\Shortcut to Premium Summary Data.lnk: Security Descriptor error: Unable to set SD
Error 1307: This security ID may not be assigned as the owner of this object.
Fixing security of z:\administration\TAIM52ST.rpt
z:\administration\TAIM52ST.rpt: Security Descriptor error: Unable to set SD
Error 1308: This security ID may not be assigned as the primary group of an object.
I have tried taking ownership of the files being copied and tried removing invalid user entriy SID's and restarting the copy for the failed folders/files, but it still will not copy.
I have tried using Robocopy and Emcopy to perform the task, and get same results with both. If I perform this task between 2 Windows file servers I have no problems. Only when I try to copy the data to the NAS do I have the problems.
Any thoughts?
In preperation, I am trying to use Robocopy or Emcopy to copy the data from our Windows File Server to the NAS.
I am trying to copy several Terabytes of data. Most copies will usually copy around 75% of the data, but there is always a group of data that will not move. It seems as though it is data with NTFS permission oddities, but even after correcting them, I often still cannot copy the data.
Here is a sample entry that is created from Robocopy:
2007/02/26 16:20:23 ERROR 1307 (0x0000051B) Copying NTFS Security to Destination Directory d:\departments\administration\Allen\
This security ID may not be assigned as the owner of this object.
2007/02/27 15:10:09 ERROR 1308 (0x0000051C) Copying NTFS Security to Destination Directory d:\departments\administration\year end\2001\
This security ID may not be assigned as the primary group of an object.
Here is a sample entry that is created from Emcopy:
Fixing security of z:\administration\Shortcut to Premium Summary Data.lnk
z:\administration\Shortcut to Premium Summary Data.lnk: Security Descriptor error: Unable to set SD
Error 1307: This security ID may not be assigned as the owner of this object.
Fixing security of z:\administration\TAIM52ST.rpt
z:\administration\TAIM52ST.rpt: Security Descriptor error: Unable to set SD
Error 1308: This security ID may not be assigned as the primary group of an object.
I have tried taking ownership of the files being copied and tried removing invalid user entriy SID's and restarting the copy for the failed folders/files, but it still will not copy.
I have tried using Robocopy and Emcopy to perform the task, and get same results with both. If I perform this task between 2 Windows file servers I have no problems. Only when I try to copy the data to the NAS do I have the problems.
Any thoughts?
Responses (0)
Solutions (0)
