
Attachment uploads are currently disabled. This is a temporary situation and will resume as normal in the coming days.
Solved!
Go to SolutionPH
pavel.heidrich
9 Posts
0
7254
June 23rd, 2015 10:00
Adding an extra network to existing MDM cluster
Hello, playing around with different network configurations I found out that it is hard to add an extra network to already established MDM cluster. Maybe you know a way how to achieve it.
In our lab we originally had one management network and one data network for Scaleio cluster on VMware (installed via vCenter plugin). Later we decided to investigate the steps needed to add a second data network (physically independent) to already running system to further increase its availability. Adding extra IP adresses to SDSs is easy and so it is for the SDCs to learn about the new available data paths. However, to have a fully redundant network setup (similar to SAN A & B in Fibre Channel world) it is also necessary to add the second network to the MDM cluster.
Because there is no command to directly achive it, I tried switching the cluster to single mode, deleting secondary MDM, deleting TB, and later adding a new secondary MDM already with two IP adresses. Unfortunatelly this doesn't work and the command fails with information that the primary and secondary MDMs need equal number of IP addresses.
# scli --add_secondary_mdm --secondary_mdm_ip 192.168.89.120,192.168.99.120
Error: MDM failed command. Status: Illegal number of IP addresses. The Primary MDM, the Secondary MDM, and the Tie-Breaker must each have the same number of IP addresses.
Responses (0)
Solutions (0)
