UNSOLVED

shegarty1

updated

20 years ago

S

shegarty1

24 Posts

0

1649

April 28th, 2006 04:00

Exchange Failover with 2003

Hi folks,
I'm trying to configure failover with Exchange 2003 adn RepliStor.

I've created the alias and it will start the services ok on the dr box.

The Outlook client however always keeps the actual server name and not the alias.

Has anyone seen this before or can you point me in the right direction?

Regards,

Stephen
  • tribicic

    157 Posts

    741

    0

    Posted April 28th, 2006 06:00

    Have you configured the exch2k.dll to change the location of the user mailboxes after the failover? exch2k.dll during failover connects to the AD and then changes the location of every user mailbox from source server to the target server. Hopefully you don't have a huge number of them. :)
  • tribicic

    157 Posts

    741

    0

    Posted April 28th, 2006 07:00

    I have checked AD and the changes have not been made.
    I am not getting any errors from RepliStor to say
    that this failed however.

    Is there a way to ensure the changes have been made?


    Yes, by checking AD.
    What you can do is to run the command manually in the CLI and see if there is any error that you get in return.
    Now at least you know the source of the problem, the only thing that is missing is the cause.
  • tribicic

    157 Posts

    741

    0

    Posted April 28th, 2006 07:00

    The Outlook client should be accessing the Exchange
    server through the alias name. When the failover
    occurs the alias is transferred to the failover box
    so Outlook can continue accessing Exchange as if
    nothing has happened.


    It is not as simple as moving the alias name across, the mailbox locations need to be updated in the AD as well.
  • DavidHampson

    2 Intern

    •

    1080 Posts

    741

    0

    Posted April 28th, 2006 07:00

    The Outlook client should be accessing the Exchange server through the alias name. When the failover occurs the alias is transferred to the failover box so Outlook can continue accessing Exchange as if nothing has happened.
  • tribicic

    157 Posts

    741

    0

    Posted April 28th, 2006 07:00

    It is normal that they revert to the physical name, but I understand you correctly they always revert to the source system name? Have you checked if the mailbox locations are actually changed in AD?
    Are the Outlook clients 2000 or 2003?
  • shegarty1

    24 Posts

    741

    0

    Posted April 28th, 2006 07:00

    I have used the exch2k.dll - in the After acvitivating failover command "exch2k.dll|Takeover %SOURCESITENETBIOS% %TARGETSITENETBIOS% %ALIAS%

    In the Before Remove Alias I have "exch2k.dll|Initialize"

    When trying to change the outlook client properites to point to the alias server it reverts to the production server hostname.
    When I failover all the clients are still pointing to the production server. I have to manually change the clients to point to the dr box instead (still using the alias name).
  • shegarty1

    24 Posts

    741

    0

    Posted April 28th, 2006 07:00

    No this is a case I am working on in Ireland.
  • shegarty1

    24 Posts

    741

    0

    Posted April 28th, 2006 07:00

    They are outlook 200 clients.

    I have checked AD and the changes have not been made. I am not getting any errors from RepliStor to say that this failed however.

    Is there a way to ensure the changes have been made?

    Thanks,

    Stephen
  • tribicic

    157 Posts

    255

    0

    Posted April 28th, 2006 08:00

    No, just start the exch2k.dll with the appropriate options in the cli, for example:
    exch2k.dll|Takeover [server1] [server2] [alias]

    ...and check if it reports any errors and changes the mailbox locations. Of course replace the server names and alias with the correct values. I also recall that the dll itself is invoked using additional tool so the command above may not be accurate.
  • shegarty1

    24 Posts

    255

    0

    Posted April 28th, 2006 08:00

    I'm not sure what syntax to use for the CLI for example:

    rep_srv cmd addalias ex-alias dr-box 255.255.0.0 /manual [/scriptaddafter exch2k.dll|Takeover %SOURCESITENETBIOS% %TARGETSITENETBIOS% %ALIAS%] [/scriptremovebefore exch2k.dll|Initialize] /addtodns /domain [/servicetostart all exchange services]

    Does this look correct?