Announcement Banner
UNSOLVED

jkgreen24

updated

15 years ago

J

jkgreen24

2 Posts

0

3157

March 6th, 2012 17:00

Using ECOM with VNX simulator

I'm trying to get the ECOM module working inside the VNX simulator. While using the TestSmiProvider and picking "addsys" I get the following error:

++++ EMCAddSystem ++++

Error: The requested object cannot be found. (com.emc.cmp.osls.se.osl.DiscoveryServices.StorInstanceDiscover():142 C:ERROR_CLASS_SOFTWARE F:ERROR_FAMILY_NOT_FOUND R:1000052 L:2 1000052 : "No objects of the requested type were found" : "SymDiscover Failed" : 2 : 40 : "No devices were found")

I tried every IP adress the system is listening on still to no avail.

Has anyone else got this working successfully in the simulator?

  • Rainer_EMC

    6 Operator

    •

    8645 Posts

    1084

    0

    Posted March 7th, 2012 13:00

    Do you mean using SMI-S for block ?

  • jkgreen24

    2 Posts

    1084

    0

    Posted March 7th, 2012 17:00

    We the VNX simulator and the ECOM module installed on the simulator, we are trying to get data in to ECOM for our testing. I'm not sure what exactly you are asking.

  • timmm1

    7 Posts

    1084

    0

    Posted March 8th, 2012 07:00

    I have the same problem. I'm get the same error when adding a storage system to the server. How to fix this?

  • Rainer_EMC

    6 Operator

    •

    8645 Posts

    1084

    0

    Posted March 12th, 2012 03:00

    If you want to use the SMI-S provider for file (NASHead profile) you need to enable it first.

    see this manual manual on Powerlink - Appendix C

     

    SMI-S Provider Programmer Guide for VNX

    P/N 300-011-846

    For SMI-S for block (SAN) you need an external ECOM server.

    See this manual on Powerlink

     

    Common Management Platform

    EMC Common Object Manager (ECOM) Toolkit

       

    ECOM Deployment and Configuration Guide

     

    P/N 300-012-941

    Rainer

  • Rainer_EMC

    6 Operator

    •

    8645 Posts

    1084

    0

    Posted March 12th, 2012 03:00

    Hi,

    I suggest to try the developer forum at http://imgforums.lss.emc.com/forum/forumdisplay.php?f=87

    AFAIK there are several ECOM parts - on the control station for SMI-S for file (nashead profile) and on the SP's and an external server for SMI-S for block.

    The VNX simulator currently is a file (NAS) simulator - it doesnt implement the block part so I wouldnt be surprised if SMI-S for block isnt functional on the VNX simulator.

    Rainer