Announcement Banner
UNSOLVED

Prakash K

updated

15 years ago

PK

Prakash K

14 Posts

1

19808

January 23rd, 2012 00:00

SQL backup failed with "BackupVirtualDeviceSet::Initialize: CoCreateInstance failure on backup device", please let me know what is the fix.

In my enivronment I am getting below failure message on 1 client. Please let know what was the issue. Thanks

Details :-

Client OS :- Windows 2003 (5.2, Build 3790)

SQL :-  Microsoft SQL 2008

Networker Server :- 7.6.2

Networker Client :- 7.6.2

Networker Module for MSSQL : -5.2.2

Error :-

4690:(pid 3608):BACKUP database [model] TO virtual_device='Legato#7a7fdb14-380c-4145-92d4-fa0e26bac640' WITH name=N'LegatoNWMSQL'

29085:(pid 3608):Microsoft SQL Server Provider error:

38006:(pid 3608):BackupVirtualDeviceSet::Initialize: CoCreateInstance failure on backup device 'Legato#7a7fdb14-380c-4145-92d4-fa0e26bac640'. Operating system error 0x80070005(failed to retrieve text for this error. Reason: 1815)..

38006:(pid 3608):BACKUP DATABASE is terminating abnormally..

29282:(pid 3608):

Backup/Recover command failed

53084:(pid 3608):Processing model failed, the item will be skipped.

nsrsqlsv: MSSQL:model level=full, 0 KB 00:00:01,  1-file(s)-processed, 0-file(s)-succeeded

Backup operation finished with error(s). Refer to the module backup log file for details.