Announcement Banner
UNSOLVED

Henrymayes

updated

11 years ago

H

Henrymayes

10 Posts

0

24019

September 18th, 2015 19:00

Raid not automatically rebuilding

Hello,

Among the servers that I have recently started to administer, I have a Powervault MD1000 that has 12 drives in a raid 6 array. I went to replace a drive in it and realized that the activity lights were not going off on all of the drives, so I figured that it was not rebuilding.

I checked and saw that apart from the bad drive that I replaced, there was also a drive in a foreign configuration. I assume that my predecessor either replaced a bad drive with a unwiped disk that was from another raid array or popped the bad disk out and back in in some attempt to see if it was a false positive. 

So, I replaced the foreign drive with another new drive. All drives show as in good status, but the raid array will not try and rebuild. I have tried to manually add the drives to the array in the controller cards boot menu, but the option does not seem to be available.

As you can see above, the Virtual drive believes those two physical drives to be missing

These are the only available operations for the VD

This is the properties of the VD

The physical disk menu shows both drives as ready

These are the only options given as operations for the two 'Ready' drives. I cannot Rebuild, Replace, Force Online or Force Offline.

I guess I could theoretically make it a Global HS and it could possibly start rebuilding based on on that, but I don't think that is the way it is suppose to be done. I would just go ahead and try making it a Global HS, but restoring all 24TB of data from the backup would be a pain if I was wrong.

If anyone could provide any insight into this, I will be very grateful.

Thank you

  • DELL-Sam L

    Community Manager

    •

    8088 Posts

    •

    34526 Points

    1927

    1

    Posted September 21st, 2015 08:00

    Hello Henrymayes,

    No what you are seeing is correct.  With the MD1000 when you have a drive that fails & have a hotspare configured then the hotspare drive takes over for the failed drive.  Now when the failed drive is replaced you will make it the hotspare drive & it will take over for the next drive that fails.  So since the 2 drives are ready if you select them you will have a 2 hotspare drives again.  Now if the array needs to be rebuilt then it will start the rebuild process once it see the hotspare drives.

    Please let us know if you have any other questions.

  • Henrymayes

    10 Posts

    1927

    0

    Posted October 1st, 2015 15:00

    The hotspare option solved the issue. Thank you for the confirmation.