
Attachment uploads are currently disabled. This is a temporary situation and will resume as normal in the coming days.
UNSOLVED
Introduce NMP settings
Introduce NMP settings
This article will introduce the NMP settings.
Detailed Information
If you look at the EMC Best Practices document, you will see the following contents:
Ensure that all servers attached to your storage array have storage path management software, such as EMC PowerPath, that is correctly installed and configured for path failover. EMC recommends a Round Robin path selection policy for XtremIO.
Firstly, let's look at what NMP is.
NMP is Native Multipathing Plug-IN.
NMP have three modes, they are MRU, Fixed and Round Robin.
- MRU (Most Recently Used): When the system starts, the system will check if the first found path can work. If the first path cannot work, it will continue to try find a workable path. When the original path is recovered, it will not failback. This is suitable for Active/Passive standby mode.
- Fixed: When the system starts, the system will check if the first found path can work. If the failure path is recovered, it will be failback. This is suitable for Active/Active mode.
- Round Robin (RR): When the system starts, the system will try to find all available paths. If the failure path is recovered, it will failback. It is the best practice recommended mode, but not all storage supports this strategy.
Next, we will introduce the NMP settings step by step.
1) Click “Configuration”
2) Click “Storage”
3) Right click and select "Properties"
4) Click “Path Management”
5) Click “Round Robin”
The Round Robin settings have been completed.
Responses (0)
Solutions (0)
