If you look at the EMC Best Practices document, you will see the following contents:
Ensure that all servers attached to your storage array have storage path management software, such as EMC PowerPath, that is correctly installed and configured for path failover. EMC recommends a Round Robin path selection policy for XtremIO.
Firstly, let's look at what NMP is.
NMP is Native Multipathing Plug-IN.
NMP have three modes, they are MRU, Fixed and Round Robin.
MRU (Most Recently Used): When the system starts, the system will check if the first found path can work. If the first path cannot work, it will continue to try find a workable path. When the original path is recovered, it will not failback. This is suitable for Active/Passive standby mode.
Fixed: When the system starts, the system will check if the first found path can work. If the failure path is recovered, it will be failback. This is suitable for Active/Active mode.
Round Robin (RR): When the system starts, the system will try to find all available paths. If the failure path is recovered, it will failback. It is the best practice recommended mode, but not all storage supports this strategy.
Next, we will introduce the NMP settings step by step.
With XtremIO, we also recommend IOPS = 1 (in addition to Round Robin) setting - which means that every IO will use a different IO path and in effect be able to leverage the active/active architecture of XtremIO to the full extent.
As always, all this is also documented in the Host Configuration Guide for XtremIO (available on the Support website).
rrukhaiyarIND
10 Posts
553
0
Posted July 20th, 2016 22:00
https://www.thomas-krenn.com/de/wiki/Was_ist_ALUA_(Asymmetric_Logical_Unit_Access)%3FGood One.
But a thing to make sure is that ALUA is enabled on the storage arrat
e.g. SATP (Storage Array Type) should show FAILOVER MODE 4 enabled (ALUA)
Helping Link -