Announcement Banner
UNSOLVED

antani2

updated

10 years ago

A

antani2

9 Posts

0

2385

March 24th, 2017 08:00

NMC 9.1.0.4 Reports not working

Hi guys,

I configured NW 9.1.0.4 and NMC on two different servers.

NMC (dcprvl002)  and NW (dcprvl002) work very well together, in fact I'm able to configure backups, vproxy, devices and so on.

The problem is that I can't generate reports from NMC because I get a "Connection refused" error, as you can see in attached image.

NW and NMC are on the same net, there is no firewall between them (no iptables, no firewalld, etc.), name resolution is working fine, ports seems good:

[root@dcprvl002 ~]# netstat -pantl | grep 5432

tcp        0      0 0.0.0.0:5432            0.0.0.0:*               LISTEN      4615/postgres

tcp        0      0 127.0.0.1:34750         127.0.0.1:5432          ESTABLISHED 4589/gstd

tcp        0      0 127.0.0.1:5432          127.0.0.1:34750         ESTABLISHED 4632/postgres: lgto

[root@dcprvl005 ~]# telnet dcprvl002 5432

Trying 10.**.**.**...

Connected to dcprvl002.

Escape character is '^]'.

^]

telnet> quit

Can you help me, please?

connection refused.PNG.png

  • ble1

    6 Operator

    •

    14354 Posts

    •

    56186 Points

    1670

    0

    Posted March 27th, 2017 09:00

    Have you checked NMC logs for any other details?

  • antani2

    9 Posts

    1670

    0

    Posted March 29th, 2017 05:00

    you mean in this path:

    /opt/lgtonmc/logs

    ?

    in here I can find these:

    gstd.raw  install.log  pg_basebackup.log  snmptrapd.log  web_output

    non of them seems logging any request

  • ble1

    6 Operator

    •

    14354 Posts

    •

    56186 Points

    1670

    0

    Posted March 29th, 2017 14:00

    And there is nothing blocking "report" port?  I don't know top of my head, but I know in older NMC implementations there was a port required to be open (free) when running reports... it might be that this port is either blocked or occupied by something else.

  • antani2

    9 Posts

    1670

    0

    Posted March 29th, 2017 15:00

    Does anybody know which port are we talking about?

    And what/who is the postmaster?

  • antani2

    9 Posts

    1670

    0

    Posted April 10th, 2017 02:00

    ok I opened an SR for this

  • 1670

    0

    Posted August 8th, 2017 05:00

    I'm facing the same problem.

    Did anyone get a solution for this problem.

  • 1670

    0

    Posted November 27th, 2017 06:00

    Facing the same problem here. Anyone got the solution?

  • bkin

    14 Posts

    1001

    0

    Posted October 22nd, 2020 11:00

    Removing, as not appropriate for OP.