Announcement Banner
UNSOLVED

Prakash K

updated

15 years ago

PK

Prakash K

14 Posts

1

19838

January 23rd, 2012 00:00

SQL backup failed with "BackupVirtualDeviceSet::Initialize: CoCreateInstance failure on backup device", please let me know what is the fix.

In my enivronment I am getting below failure message on 1 client. Please let know what was the issue. Thanks

Details :-

Client OS :- Windows 2003 (5.2, Build 3790)

SQL :-  Microsoft SQL 2008

Networker Server :- 7.6.2

Networker Client :- 7.6.2

Networker Module for MSSQL : -5.2.2

Error :-

4690:(pid 3608):BACKUP database [model] TO virtual_device='Legato#7a7fdb14-380c-4145-92d4-fa0e26bac640' WITH name=N'LegatoNWMSQL'

29085:(pid 3608):Microsoft SQL Server Provider error:

38006:(pid 3608):BackupVirtualDeviceSet::Initialize: CoCreateInstance failure on backup device 'Legato#7a7fdb14-380c-4145-92d4-fa0e26bac640'. Operating system error 0x80070005(failed to retrieve text for this error. Reason: 1815)..

38006:(pid 3608):BACKUP DATABASE is terminating abnormally..

29282:(pid 3608):

Backup/Recover command failed

53084:(pid 3608):Processing model failed, the item will be skipped.

nsrsqlsv: MSSQL:model level=full, 0 KB 00:00:01,  1-file(s)-processed, 0-file(s)-succeeded

Backup operation finished with error(s). Refer to the module backup log file for details.

  • Panwar

    79 Posts

    5124

    0

    Posted January 23rd, 2012 03:00

    Hi,

    Please provide the saveset details of SQL client set on the NMC  and nsrsqlsv log file under \nsr\appslog from the Client machine.

    Regards

    Panwar

  • Prakash K

    14 Posts

    5124

    0

    Posted January 23rd, 2012 03:00

    Hi Panwar,

    I have tried all available user name and using "Saveset - MSSQL:" . Thanks in advance.

    nsrsqlsv log:-

     

    43708 1327304188 1 0 0 2468 3608 0 dcdb003t (pid3608) 14 Start time: %s 1 35 25 Mon Jan 23 08:36:28 2012

    43621 1327304188 1 0 0 2468 3608 0 dcdb003t (pid3608) 35 Computer Name: %s User Name: %s 2 12 8 DCDB003T 13 7 wmdrift

    52702 1327304188 1 0 0 2468 3608 0 dcdb003t (pid3608) 33 System Version: %d.%d Build %d %s 4 1 1 5 1 1 2 1 4 3790 0 1 S

    37975 1327304188 1 0 0 2468 3608 0 dcdb003t (pid3608) 49 Microsoft Data Access Component(MDAC) version: %s 1 0 11 2.82.3959.0

    37980 1327304188 1 0 0 2468 3608 0 dcdb003t (pid3608) 49 Microsoft SQL Server version (from registry) : %s 1 0 11 10.0.4000.0

    29446 1327304188 1 0 0 2468 3608 0 dcdb003t (pid3608) 44 Local host has following SQL Server online: 0

    37977 1327304188 1 0 0 2468 3608 0 dcdb003t (pid3608) 19 MSSQL server : %s 1 0 8 DCDB003T

    37982 1327304188 1 0 0 2468 3608 0 dcdb003t (pid3608) 33 Use Legato Networker Server : %s 1 0 10 nw5sesto01

    37983 1327304188 1 0 0 2468 3608 0 dcdb003t (pid3608) 35 Legato Networker Server Version: %s 1 0 45 NetWorker 7.6.2.5.Build.681 Power Edition/512

    73064 1327304188 1 0 0 2468 3608 0 dcdb003t (pid3608) 81 Version information for %s:\n Original file name: %s\n Version: %s\n Comments: %s 4 0 44 C:\Program Files\Legato\nsr\bin\nsrexecd.exe 0 12 nsrexecd.exe 0 17 7.6.2.1.Build.638 0 0

    73064 1327304188 1 0 0 2468 3608 0 dcdb003t (pid3608) 81 Version information for %s:\n Original file name: %s\n Version: %s\n Comments: %s 4 0 44 C:\Program Files\Legato\nsr\bin\nsrsqlsv.exe 0 12 nsrsqlsv.exe 0 8 5.2.2.23 0 55 Supporting SQL 2000, SQL 2005, SQL 2008 and SQL 2008 R2

    43337 1327304188 1 0 0 2468 3608 0 dcdb003t (pid3608) 13 Command line: 0

    43338 1327304188 1 0 0 2468 3608 0 dcdb003t (pid3608) 4 %s 1 0 28 nsrsqlsv -s nw5sesto01 -I -

    37693 1327304188 1 0 0 2468 3608 0 dcdb003t (pid3608) 57 SQL Connection to %s is created. SQL Server Version is %s 2 0 8 DCDB003T 0 10 10.00.4064

    52757 1327304189 1 0 0 2468 3608 0 dcdb003t (pid3608) 25 Command line -I item: %s 1 0 14 "MSSQL:model"

    37994 1327304190 1 0 0 2468 3608 0 dcdb003t (pid3608) 16 Backing up %s... 1 0 5 model

    4690 1327304190 1 0 0 2468 3608 0 dcdb003t (pid3608) 2 %s 1 0 113 BACKUP database [model] TO virtual_device='Legato#7a7fdb14-380c-4145-92d4-fa0e26bac640' WITH name=N'LegatoNWMSQL'

    29085 1327304190 5 0 0 2772 3608 0 dcdb003t (pid3608) 36 Microsoft SQL Server Provider error: 0

    38006 1327304190 5 0 0 2772 3608 0 dcdb003t (pid3608) 3 %s. 1 24 213 BackupVirtualDeviceSet::Initialize: CoCreateInstance failure on backup device 'Legato#7a7fdb14-380c-4145-92d4-fa0e26bac640'. Operating system error 0x80070005(failed to retrieve text for this error. Reason: 1815).

    38006 1327304190 5 0 0 2772 3608 0 dcdb003t (pid3608) 3 %s. 1 24 42 BACKUP DATABASE is terminating abnormally.

    29282 1327304190 5 0 0 2468 3608 0 dcdb003t (pid3608) 31 \nBackup/Recover command failed 0

    53084 1327304190 5 0 0 2468 3608 0 dcdb003t (pid3608) 47 Processing %s failed, the item will be skipped. 1 0 5 model

    43709 1327304190 1 0 0 2468 3608 0 dcdb003t (pid3608) 13 Stop time: %s 1 35 25 Mon Jan 23 08:36:30 2012

    43708 1327306940 1 0 0 3360 944 0 dcdb003t (pid944) 14 Start time: %s 1 35 25 Mon Jan 23 09:22:20 2012

    43621 1327306940 1 0 0 3360 944 0 dcdb003t (pid944) 35 Computer Name: %s User Name: %s 2 12 8 DCDB003T 13 7 wmdrift

    52702 1327306940 1 0 0 3360 944 0 dcdb003t (pid944) 33 System Version: %d.%d Build %d %s 4 1 1 5 1 1 2 1 4 3790 0 1 S

    37975 1327306940 1 0 0 3360 944 0 dcdb003t (pid944) 49 Microsoft Data Access Component(MDAC) version: %s 1 0 11 2.82.3959.0

    37980 1327306940 1 0 0 3360 944 0 dcdb003t (pid944) 49 Microsoft SQL Server version (from registry) : %s 1 0 11 10.0.4000.0

    29446 1327306940 1 0 0 3360 944 0 dcdb003t (pid944) 44 Local host has following SQL Server online: 0

    37977 1327306940 1 0 0 3360 944 0 dcdb003t (pid944) 19 MSSQL server : %s 1 0 8 DCDB003T

    37982 1327306940 1 0 0 3360 944 0 dcdb003t (pid944) 33 Use Legato Networker Server : %s 1 0 10 nw5sesto01

    37983 1327306940 1 0 0 3360 944 0 dcdb003t (pid944) 35 Legato Networker Server Version: %s 1 0 45 NetWorker 7.6.2.5.Build.681 Power Edition/512

    73064 1327306940 1 0 0 3360 944 0 dcdb003t (pid944) 81 Version information for %s:\n Original file name: %s\n Version: %s\n Comments: %s 4 0 44 C:\Program Files\Legato\nsr\bin\nsrexecd.exe 0 12 nsrexecd.exe 0 17 7.6.2.1.Build.638 0 0

    73064 1327306940 1 0 0 3360 944 0 dcdb003t (pid944) 81 Version information for %s:\n Original file name: %s\n Version: %s\n Comments: %s 4 0 44 C:\Program Files\Legato\nsr\bin\nsrsqlsv.exe 0 12 nsrsqlsv.exe 0 8 5.2.2.23 0 55 Supporting SQL 2000, SQL 2005, SQL 2008 and SQL 2008 R2

    43337 1327306940 1 0 0 3360 944 0 dcdb003t (pid944) 13 Command line: 0

    43338 1327306940 1 0 0 3360 944 0 dcdb003t (pid944) 4 %s 1 0 28 nsrsqlsv -s nw5sesto01 -I -

    37693 1327306940 1 0 0 3360 944 0 dcdb003t (pid944) 57 SQL Connection to %s is created. SQL Server Version is %s 2 0 8 DCDB003T 0 10 10.00.4064

    52757 1327306942 1 0 0 3360 944 0 dcdb003t (pid944) 25 Command line -I item: %s 1 0 14 "MSSQL:model"

    37994 1327306942 1 0 0 3360 944 0 dcdb003t (pid944) 16 Backing up %s... 1 0 5 model

    4690 1327306942 1 0 0 3360 944 0 dcdb003t (pid944) 2 %s 1 0 113 BACKUP database [model] TO virtual_device='Legato#c5cc2aef-b3e3-437f-b623-1ed7070d1da5' WITH name=N'LegatoNWMSQL'

    29085 1327306942 5 0 0 3528 944 0 dcdb003t (pid944) 36 Microsoft SQL Server Provider error: 0

    38006 1327306942 5 0 0 3528 944 0 dcdb003t (pid944) 3 %s. 1 24 213 BackupVirtualDeviceSet::Initialize: CoCreateInstance failure on backup device 'Legato#c5cc2aef-b3e3-437f-b623-1ed7070d1da5'. Operating system error 0x80070005(failed to retrieve text for this error. Reason: 1815).

    38006 1327306942 5 0 0 3528 944 0 dcdb003t (pid944) 3 %s. 1 24 42 BACKUP DATABASE is terminating abnormally.

    29282 1327306942 5 0 0 3360 944 0 dcdb003t (pid944) 31 \nBackup/Recover command failed 0

    53084 1327306942 5 0 0 3360 944 0 dcdb003t (pid944) 47 Processing %s failed, the item will be skipped. 1 0 5 model

    43709 1327306942 1 0 0 3360 944 0 dcdb003t (pid944) 13 Stop time: %s 1 35 25 Mon Jan 23 09:22:22 2012

  • CarlosRojas

    1 Rookie

    •

    1693 Posts

    5124

    0

    Posted January 23rd, 2012 21:00

    Hi Pkk1234,

    Usually in Microsoft, this kind of output (0x80070005) means permission denied, so I guess that the problem is related to permissions. Please ensure that the client configuration in NetWorker has set a username and password with enough permissions on SQL DB's in the Remote User field.

    You would like to look into the Application, System and Security event logs on the SQL server to gather more information.

    Thank you.

    Carlos.

  • Prakash K

    14 Posts

    5124

    0

    Posted January 24th, 2012 02:00

    Hi,

    Thanks for your update. I have confirmed with SQL DBA and updated Client configuration. Even though getting the same.

  • CarlosRojas

    1 Rookie

    •

    1693 Posts

    5124

    0

    Posted January 24th, 2012 03:00

    Hi again,

    Did you check the Application and System event logs in Event Viewer of the SQL server? Also check the Security ones, in case there is a permissions related one.

    In the other hand having the log rendered would help a bit more. Please render it as follows from file location path (C:\Program Files\Legato\nsr\applogs)

    nsr_render_log nsrsqlsv.raw > nsrsqlsv.log

    Please attach the output here.

    Also check the user starting up NetWorker services, and try to logon into the SQL server using the same user as the one you have specified in the SQL client resource in NetWorker and try to run a manual backup of any of the DB's using NMSQL GUI. Let us know the results.

    Thank you.

    Carlos.

  • Prakash K

    14 Posts

    5124

    0

    Posted January 25th, 2012 00:00

    Thanks Again,

    Nothing found in Security and System event viewer. In the Application I found the below messages. SQL team are using the same user account to take a local backup.

     

    SQLVDI: Loc=SignalAbort. Desc=Client initiates abort. ErrorCode=(0). Process=3504. Thread=4028. Client. Instance=. VD=Global\Legato#438f43b7-c6ec-41c5-84b2-9b8030669757_SQLVDIMemoryName_0.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    BackupVirtualDeviceSet::Initialize: CoCreateInstance failure on backup device 'Legato#8b86cddc-40a4-4e09-9695-51621e9f3a78'. Operating system error 0x80070005(failed to retrieve text for this error. Reason: 1815).

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Regards,

    Prakash

  • CarlosRojas

    1 Rookie

    •

    1693 Posts

    5124

    0

    Posted January 25th, 2012 02:00

    Hi Again,

    You would like to take a look at the following MS KB:

    https://support.microsoft.com/kb/830575

    Also note that Microsoft MSDN recommends that the two SQL Server Services be logged in using either the local system account or a domain account that has the necessary rights to run SQL Services (see URL below). When SQL Server 2000 is installed on a domain controller, refrain from using \ or .\ .

    http://msdn2.microsoft.com/en-us/library/Aa176610

    If that doesn't help you should try to run a manual backup from SQL server using NMSQL GUI and please let us know the results.

    Thank you.

    Carlos.

  • ble1

    6 Operator

    •

    14354 Posts

    •

    56186 Points

    5124

    0

    Posted January 27th, 2012 04:00

    Do you get the same error when doing client side initiated SQL backup?

  • Prakash K

    14 Posts

    5124

    0

    Posted January 27th, 2012 06:00

    Hi,

    Yes, we are getting the same error while initiating manual backup from the client side through "Networker users for SQL". Thanks

  • CarlosRojas

    1 Rookie

    •

    1693 Posts

    1896

    0

    Posted January 29th, 2012 21:00

    Hey Pkk1234

    Did you check my post on the 25th?

    Did you try to re-register sqlvdi.dll and the users information?

    Please re-register sqlvdi and reboot the SQL server.

    After that run a new backup, if it fails then please provide us with the following information:

    On SQL open command prompt and go to this path:

    C:\Program Files\Legato\nsr\applogs

    Then run this command:

    nsr_render_log nsrsqlsv.raw > nsrsqlsv.log

    Then open nsrsqlsv.log and please check the latest lines and paste them here together with the latest lines of the XBSA file in the same path.

    Thank you.

    Carlos.