SQL backup failed with "BackupVirtualDeviceSet::Initialize: CoCreateInstance
failure on backup device", please let me know what is the fix.
In my enivronment I am getting below failure message on 1 client. Please let know what was the issue. Thanks
Details :-
Client OS :- Windows 2003 (5.2, Build 3790)
SQL :- Microsoft SQL 2008
Networker Server :- 7.6.2
Networker Client :- 7.6.2
Networker Module for MSSQL : -5.2.2
Error :-
4690:(pid 3608):BACKUP database [model] TO virtual_device='Legato#7a7fdb14-380c-4145-92d4-fa0e26bac640' WITH name=N'LegatoNWMSQL'
29085:(pid 3608):Microsoft SQL Server Provider error:
38006:(pid 3608):BackupVirtualDeviceSet::Initialize: CoCreateInstance failure on backup device 'Legato#7a7fdb14-380c-4145-92d4-fa0e26bac640'. Operating system error 0x80070005(failed to retrieve text for this error. Reason: 1815)..
38006:(pid 3608):BACKUP DATABASE is terminating abnormally..
29282:(pid 3608):
Backup/Recover command failed
53084:(pid 3608):Processing model failed, the item will be skipped.
Usually in Microsoft, this kind of output (0x80070005) means permission denied, so I guess that the problem is related to permissions. Please ensure that the client configuration in NetWorker has set a username and password with enough permissions on SQL DB's in the Remote User field.
You would like to look into the Application, System and Security event logs on the SQL server to gather more information.
Did you check the Application and System event logs in Event Viewer of the SQL server? Also check the Security ones, in case there is a permissions related one.
In the other hand having the log rendered would help a bit more. Please render it as follows from file location path (C:\Program Files\Legato\nsr\applogs)
nsr_render_log nsrsqlsv.raw > nsrsqlsv.log
Please attach the output here.
Also check the user starting up NetWorker services, and try to logon into the SQL server using the same user as the one you have specified in the SQL client resource in NetWorker and try to run a manual backup of any of the DB's using NMSQL GUI. Let us know the results.
Nothing found in Security and System event viewer. In the Application I found the below messages. SQL team are using the same user account to take a local backup.
BackupVirtualDeviceSet::Initialize: CoCreateInstance failure on backup device 'Legato#8b86cddc-40a4-4e09-9695-51621e9f3a78'. Operating system error 0x80070005(failed to retrieve text for this error. Reason: 1815).
Also note that Microsoft MSDN recommends that the two SQL Server Services be logged in using either the local system account or a domain account that has the necessary rights to run SQL Services (see URL below). When SQL Server 2000 is installed on a domain controller, refrain from using \ or .\ .
Panwar
79 Posts
5124
0
Posted January 23rd, 2012 03:00
Hi,
Please provide the saveset details of SQL client set on the NMC and nsrsqlsv log file under \nsr\appslog from the Client machine.
Regards
Panwar