The vApp powers on properly but when logging into the web GUI two errors pop out:
1. One or more of the ProSphere virtual machines was not ready to run the ProSphere Console. Loading the Console may result in a incomplete display of data. Details: The status check for the Historical Database virtual machine has either timed out or run into errors. Check if the virtual machine´s Service Monitor is running.
2. Error ID: CAP-3001. An unknown UI Service error occurred while executing the request. HTTP fault:500
For the second error, I have read here that this can be "resolved on updating to ProSphere 1.6." but I installed version 1.7...
The srm-vapp-information is the file where the appliance hostnames are found by the system when completing the status checks.
Login to the SRM Appliance host and change directory (cd) to the following location: /usr/share/tomcat6/webapps/login-monitor/WEB-INF/classes/ Run the cat command to view the contents of the srm-vapp-information file:
cat srm-vapp-information | more
Do you see the correct FQDN for HistoricalDatabase.hostname= (all lower case) and IP for HistoricalDatabase.ip=?
If the errors only appeared after a few days of a good deployment please log into the Historical Database and run the command Service --status-all and review
I checked that post and I have the DNS properly configured in both directions (using the nsklookup it returns both the name and the ip given the ip and name respectively).
Also, the hostsnames do not contain underscores, only dashes (i.e. pro-sphere-app.xxxxx, pro-sphere-de.xxxxx, pro-sphere-hdb.xxxxx)
Also I have all those parameters that you say properly set up.
I have powered off and on again the vApp and those errors still pop out.
The errors have not appeared after a few days, it is the first time I run the GUI and would like to configure the discovers.
I solved the second error. It does not appear now.
The greenplum service now is working.
But now the error "The status check for the Historical Database virtual machine has either timed out or run into errors. Check if the virtual machine´s Service Monitor is running" is still there...
I have redeployed the vApp again because there was a problem with the naming. I have checked this file on the StorageResourceManager and yes, the names and the IPs now are correct.
But a new problem has just come up... . When I loggin into one of the VM and have a look at the routing tables, they are empty! I remember that I did not do any network configuration for each VM.
ConorLawlor
2 Intern
•
233 Posts
1150
0
Posted February 5th, 2013 08:00
Hi,
The srm-vapp-information is the file where the appliance hostnames are found by the system when completing the status checks.
Login to the SRM Appliance host and change directory (cd) to the following location: /usr/share/tomcat6/webapps/login-monitor/WEB-INF/classes/ Run the cat command to view the contents of the srm-vapp-information file:
cat srm-vapp-information | more
Do you see the correct FQDN for HistoricalDatabase.hostname= (all lower case) and IP for HistoricalDatabase.ip=?
Regards
Conor