
UNSOLVED
Scheduled backups fail on DB2 Version 9.1 on AIX 5.3
Backup Server:Red hat 3.0,Legato NetWorker 7.3.2
Client A: 64 bit AIX 5.3 with HACMP,64 bit DB2 v9.1.0.1,NetWorker 7.3.2 Client,NetWorker Module for DB2 2.1
Client B: 64 bit AIX 5.3 with HACMP,64 bit DB2 v9.1.0.1,NetWorker 7.3.2 Client,NetWorker Module for DB2 2.1
I can manual backup DB2 database successful。I have downloaded and installed the latest NMDB2 (LGTpa91317) hotfix:
gunzip nmdb221_LGTpa91317.aix51w.tar.gz
tar -xvf nmdb221_LGTpa91317.aix51w.tar
mv /usr/bin/nsrdb2sv /usr/bin/nsrdb2svbak
cp nsrdb2sv /usr/bin
nsrdb2sv -f /nsr/script/db2_cfg -P qwe!@#123
04/03/07 21:31:46 nsrdb2sv: Password encryption is successful.
ln -s /usr/opt/IBM/db2/V9.1/lib64 /usr/opt/db2_08_01/lib64
(My DB2 Product is installed at "/usr/opt/IBM/db2/V9.1".)
I have created group "test" with physical hostnames client,but Scheduled backups fail on DB2 Version 9.1 on AIX 5.3
Save Set: DB2:/iabakdb/NODE0000
Remote Access:*@*
Backup Command: nsrdb2sv -f /nsr/script/db2_cfg
Remote user:insttest
Password:qwe!@#123
[root@iacibaksrv root]# savegrp -l Full -Gv test
iacidbsrv1:DB2:/iabakdb/NODE0000 level=full
04/04/07 01:07:03 savegrp: Group will not limit job parallelism
04/04/07 01:07:03 savegrp: iacidbsrv1:probe started
savefs -s iacibaksrv -c iacidbsrv1 -g test -p -l full -R -v -F DB2:/iabakdb/NODE0000
iacidbsrv1:DB2:/iabakdb/NODE0000 level=full, dn=0, mx=1, vers=pools, p=4
* iacidbsrv1:Probe savefs iacidbsrv1: succeeded.
04/04/07 01:07:03 savegrp: iacidbsrv1:probe succeeded.
04/04/07 01:07:03 savegrp: iacidbsrv1:DB2:/iabakdb/NODE0000 started
nsrdb2sv -f /nsr/script/db2_cfg -s iacibaksrv -g test -LL -m iacidbsrv1 -l full -W 78 -N DB2:/iabakdb/NODE0000 DB2:/iabakdb/NODE0000
04/04/07 01:07:04 savegrp: command 'nsrdb2sv -f /nsr/script/db2_cfg -s iacibaksrv -g test -LL -m iacidbsrv1 -l full -W 78 -N DB2:/iabakdb/NODE0000 DB2:/iabakdb/NODE0000 ' for client iacidbsrv1 exited with return code 255.
* iacidbsrv1:DB2:/iabakdb/NODE0000 04/04/07 01:11:53 nsrdb2sv: Writing debug messages to /nsr/applogs/nsrdb2sv.log
* iacidbsrv1:DB2:/iabakdb/NODE0000 04/04/07 01:11:53 nsrdb2sv:
04/04/07 01:07:04 savegrp: iacidbsrv1:DB2:/iabakdb/NODE0000 failed.
04/04/07 01:07:04 savegrp: iacidbsrv1:DB2:/iabakdb/NODE0000 will retry 1 more time(s)
04/04/07 01:07:04 savegrp: iacidbsrv1:DB2:/iabakdb/NODE0000 started
nsrdb2sv -f /nsr/script/db2_cfg -s iacibaksrv -g test -LL -m iacidbsrv1 -l full -W 78 -N DB2:/iabakdb/NODE0000 DB2:/iabakdb/NODE0000
04/04/07 01:07:04 savegrp: command 'nsrdb2sv -f /nsr/script/db2_cfg -s iacibaksrv -g test -LL -m iacidbsrv1 -l full -W 78 -N DB2:/iabakdb/NODE0000 DB2:/iabakdb/NODE0000 ' for client iacidbsrv1 exited with return code 255.
* iacidbsrv1:DB2:/iabakdb/NODE0000 1 retry attempted
* iacidbsrv1:DB2:/iabakdb/NODE0000 04/04/07 01:11:54 nsrdb2sv: Writing debug messages to /nsr/applogs/nsrdb2sv.log
* iacidbsrv1:DB2:/iabakdb/NODE0000 04/04/07 01:11:54 nsrdb2sv:
04/04/07 01:07:04 savegrp: iacidbsrv1:DB2:/iabakdb/NODE0000 failed.
04/04/07 01:07:04 savegrp: iacidbsrv1:index started
save -s iacibaksrv -S -g test -LL -f - -m iacibaksrv -V -l full -LL -W 78 -N index:37deb87d-00000004-46110925-46111c11-00050000-58210009 /nsr/index/iacidbsrv1
iacidbsrv1/nsr/applogs>more nsrdb2sv.log
4/04/07 00:07:14 nsrdb2sv: *** NetWorker Module for DB2 backup session started (1090156) ***
04/04/07 00:07:14 nsrdb2sv: Function libdb2api:ClientConnectionAttrisSet - Node Change returned error -1390.
04/04/07 00:07:14 nsrdb2sv: NMDB2_ERROR: Could not set communication to connect to node 0000
04/04/07 00:07:14 nsrdb2sv: *** NetWorker Module for DB2 backup session started (823736) ***
04/04/07 00:07:14 nsrdb2sv: Function libdb2api:ClientConnectionAttrisSet - Node Change returned error -1390.
04/04/07 00:07:14 nsrdb2sv: NMDB2_ERROR: Could not set communication to connect to node 0000
I have created group "iacidbsrv1_svc_db" with virtual hostnames client,also Scheduled backups fail.
Pls help me !
Client A: 64 bit AIX 5.3 with HACMP,64 bit DB2 v9.1.0.1,NetWorker 7.3.2 Client,NetWorker Module for DB2 2.1
Client B: 64 bit AIX 5.3 with HACMP,64 bit DB2 v9.1.0.1,NetWorker 7.3.2 Client,NetWorker Module for DB2 2.1
I can manual backup DB2 database successful。I have downloaded and installed the latest NMDB2 (LGTpa91317) hotfix:
gunzip nmdb221_LGTpa91317.aix51w.tar.gz
tar -xvf nmdb221_LGTpa91317.aix51w.tar
mv /usr/bin/nsrdb2sv /usr/bin/nsrdb2svbak
cp nsrdb2sv /usr/bin
nsrdb2sv -f /nsr/script/db2_cfg -P qwe!@#123
04/03/07 21:31:46 nsrdb2sv: Password encryption is successful.
ln -s /usr/opt/IBM/db2/V9.1/lib64 /usr/opt/db2_08_01/lib64
(My DB2 Product is installed at "/usr/opt/IBM/db2/V9.1".)
I have created group "test" with physical hostnames client,but Scheduled backups fail on DB2 Version 9.1 on AIX 5.3
Save Set: DB2:/iabakdb/NODE0000
Remote Access:*@*
Backup Command: nsrdb2sv -f /nsr/script/db2_cfg
Remote user:insttest
Password:qwe!@#123
[root@iacibaksrv root]# savegrp -l Full -Gv test
iacidbsrv1:DB2:/iabakdb/NODE0000 level=full
04/04/07 01:07:03 savegrp: Group will not limit job parallelism
04/04/07 01:07:03 savegrp: iacidbsrv1:probe started
savefs -s iacibaksrv -c iacidbsrv1 -g test -p -l full -R -v -F DB2:/iabakdb/NODE0000
iacidbsrv1:DB2:/iabakdb/NODE0000 level=full, dn=0, mx=1, vers=pools, p=4
* iacidbsrv1:Probe savefs iacidbsrv1: succeeded.
04/04/07 01:07:03 savegrp: iacidbsrv1:probe succeeded.
04/04/07 01:07:03 savegrp: iacidbsrv1:DB2:/iabakdb/NODE0000 started
nsrdb2sv -f /nsr/script/db2_cfg -s iacibaksrv -g test -LL -m iacidbsrv1 -l full -W 78 -N DB2:/iabakdb/NODE0000 DB2:/iabakdb/NODE0000
04/04/07 01:07:04 savegrp: command 'nsrdb2sv -f /nsr/script/db2_cfg -s iacibaksrv -g test -LL -m iacidbsrv1 -l full -W 78 -N DB2:/iabakdb/NODE0000 DB2:/iabakdb/NODE0000 ' for client iacidbsrv1 exited with return code 255.
* iacidbsrv1:DB2:/iabakdb/NODE0000 04/04/07 01:11:53 nsrdb2sv: Writing debug messages to /nsr/applogs/nsrdb2sv.log
* iacidbsrv1:DB2:/iabakdb/NODE0000 04/04/07 01:11:53 nsrdb2sv:
04/04/07 01:07:04 savegrp: iacidbsrv1:DB2:/iabakdb/NODE0000 failed.
04/04/07 01:07:04 savegrp: iacidbsrv1:DB2:/iabakdb/NODE0000 will retry 1 more time(s)
04/04/07 01:07:04 savegrp: iacidbsrv1:DB2:/iabakdb/NODE0000 started
nsrdb2sv -f /nsr/script/db2_cfg -s iacibaksrv -g test -LL -m iacidbsrv1 -l full -W 78 -N DB2:/iabakdb/NODE0000 DB2:/iabakdb/NODE0000
04/04/07 01:07:04 savegrp: command 'nsrdb2sv -f /nsr/script/db2_cfg -s iacibaksrv -g test -LL -m iacidbsrv1 -l full -W 78 -N DB2:/iabakdb/NODE0000 DB2:/iabakdb/NODE0000 ' for client iacidbsrv1 exited with return code 255.
* iacidbsrv1:DB2:/iabakdb/NODE0000 1 retry attempted
* iacidbsrv1:DB2:/iabakdb/NODE0000 04/04/07 01:11:54 nsrdb2sv: Writing debug messages to /nsr/applogs/nsrdb2sv.log
* iacidbsrv1:DB2:/iabakdb/NODE0000 04/04/07 01:11:54 nsrdb2sv:
04/04/07 01:07:04 savegrp: iacidbsrv1:DB2:/iabakdb/NODE0000 failed.
04/04/07 01:07:04 savegrp: iacidbsrv1:index started
save -s iacibaksrv -S -g test -LL -f - -m iacibaksrv -V -l full -LL -W 78 -N index:37deb87d-00000004-46110925-46111c11-00050000-58210009 /nsr/index/iacidbsrv1
iacidbsrv1/nsr/applogs>more nsrdb2sv.log
4/04/07 00:07:14 nsrdb2sv: *** NetWorker Module for DB2 backup session started (1090156) ***
04/04/07 00:07:14 nsrdb2sv: Function libdb2api:ClientConnectionAttrisSet - Node Change returned error -1390.
04/04/07 00:07:14 nsrdb2sv: NMDB2_ERROR: Could not set communication to connect to node 0000
04/04/07 00:07:14 nsrdb2sv: *** NetWorker Module for DB2 backup session started (823736) ***
04/04/07 00:07:14 nsrdb2sv: Function libdb2api:ClientConnectionAttrisSet - Node Change returned error -1390.
04/04/07 00:07:14 nsrdb2sv: NMDB2_ERROR: Could not set communication to connect to node 0000
I have created group "iacidbsrv1_svc_db" with virtual hostnames client,also Scheduled backups fail.
Pls help me !
Responses (0)
Solutions (0)
