UNSOLVED

don_caruana

updated

9 years ago

0

1215

October 18th, 2017 18:00

nfs locks aren't working after upgrade to 8.x

After upgrading to 8.0.0.4, nfs locks are no longer working properly. If applications try to get an exclusive lock, it will error with "No locks available." If we mount with "nolock", then everything that tries to get an exclusive lock is "granted" one, meaning that actually nobody has an exclusive lock, even though they think they do. Obviously this is a big data corruption issue.

We have nfsv4 disabled, so these are all nfsv3 mounts. This wasn't a problem at all before the upgrade. All the appropriate services are running on the servers mounting this Isilon and they're able to mount other Isilon with no issues with locks. Its just this one Isilon that's a problem.

It seems there's something fundamentally messed up with this Isilon or there's a setting somewhere we missed.

What could be causing this behavior and how do we correct it?