I followed the steps exactly and now i'm stuck at Task 2: Step 4. I have changed the hostname in both the local hosts file and DNS and rebooted the server. I was expecting it to automatically create a new client resource in the Networker server with the new hostname.
What happened is that the Networker Backup and Recover service will not start and i opened the daemon.raw file and found the following error:
Networker is unable to continue its startup due to a server hostname change to "%s". Please verify that the server's hostname and it's aliases are properly represented in the local host database (eg. /etc/hosts) and DNS.
I have configured the hosts file correctly and here how it looks like:
Have seen this do it more than often. You will have to create the temp client instance manually using the nsradmin command with the NetWorker services down. Or you could put the old name back, create the client instance for the temp name and do the renaming of the server again. I assume you would choose the first option easier i.e. creating the temp client instance using nsradmin, here are the steps.
- assuming you are on windws - nsradmin -d path_where_networker_is_installed/nsr/res/nsrdb
I found the solution for the NMC. you must run the command gstconfig from the NMC installation path and the hostname for the NMC will be updated. without that even if you connect with http://localhost:9000 it will not work.
Thanks for posting your solution Ahmed. I too was unable to connect to the NMC until I ran the 'gstconfig' command from C:\Program Files\EMC Networker\Management\GST\bin.
crazyrov
6 Operator
•
1319 Posts
1807
1
Posted November 26th, 2014 22:00
Hi Ahmed,
Have seen this do it more than often. You will have to create the temp client instance manually using the nsradmin command with the NetWorker services down. Or you could put the old name back, create the client instance for the temp name and do the renaming of the server again. I assume you would choose the first option easier i.e. creating the temp client instance using nsradmin, here are the steps.
- assuming you are on windws - nsradmin -d path_where_networker_is_installed/nsr/res/nsrdb
- create type: nsr client; name: new_temp_name; aliases: new_temp_name.domain.com
- yes
- quit
- start the services.