we develop a files archiving solutions for Windows, that should be compatible also with Celerra.
When I try to copy offline file in explorer.exe and file is bigger then 64kb explorer caused exception 0x8007054F.
Offline file is during copying downloaded via HTTP into temporary file and then is replaced original file by content partial chunks. HTTP download is requested by EMC Celerra.
Copying by cmd line or another file manager is always OK. Also IE download by accessing the url web service is OK.
Explorer cause exception randomly. Sometimes the file didn't start to be downloaded, some other time it crash before finish. When 0x8007054F occurs explorer 'copy file' dialog allow user 'try again' copying and the file is downloaded anyway.
Also we get this in log on Celerra:
logged time = 2013-10-01 09:02:27 id = 13159628813 severity = ERROR component = DART facility = DHSM baseid = 13 type = STATUS argument name = httpStatusString argument value = 202 Accepted argument type = string (8) argument name = httpStatus argument value = 0xCA argument type = integer32 (2) brief description = Unexpected HTTP status 202 Accepted during read operation for a GET request. full description = After the HTTP client sent a GET request to the HTTP server, the HTTP server returned a status code that was neither 200(OK) nor 205 (Partial Content). recommended action = 1. Use that status code to troubleshoot the problem. 2. If the status code is '1006 Connection Disconnected' this means that the Data Mover was unable to establish or u se a TCP connection to the HTTP server. Verify that the HTTP server is up and running on the correct port. This may be done with ... telnet {HTTP server} {port}. Verify that the HTTP server is accessible to the Data Mover on the network. This can be done by executing server_p ing server_x {HTTP server} on the Control Station. 3. View the Data Mover server log to get more information. 4. Contact the HTTP server vendor. 5. Collect a network trace if the problem is repeatable.
Any ideas what that can be ? Because for Partial Content we are sending 206 which is correct HTTP status . If we changed it to 205, we got the same error.
full description = No additional information is available.
recommended action = No recommended action is available. For more information and assistance: 1. Log into http://powerlink.emc.com and go to Support > Search Support. 2. Use the message ID or text from the error message's brief description to search.
maybe it would be helpful to let you know, that we found out, that we had the same issue with Celerra Sim 5.5 and 5.6 . Our developers received some hotfix from Celerra Sim team but it was a long time ago. Also, to my understanding, this issue happens only with simulators. Our developers were promised that the hotfix would be in new build of Sim - but it was and old communication like 7 years ago.
Just for your information - maybe it will help somehow
We found some SR number, but it's from our client company .. but I do not want to publish it here, can I send it to you? To your email for example ? Will it help somehow ?
Rainer_EMC
6 Operator
•
8645 Posts
484
0
Posted October 7th, 2013 08:00
Hi,
can you provide some more details ?
From your description it looks like you are talking about offline files that use the FileMover (DHSM) functionality.
Is your application manageing that or is it an EMC appliation like CFA?
what protocol is used to access the archived data? NFS/CIFS or http?
Rainer