UNSOLVED

Drejc

updated

17 years ago

D

Drejc

1 Rookie

8 Posts

0

3032

June 18th, 2009 03:00

NetWorker 7.5.1 - problem with backup of MaxDB database

Dear NetWorker fans!

We are using Networker 7.5 SP1 (server on Linux RH, 64-bit) now. We are using MaxDB 7.7 (7.7.04.28) database backup over NetWorker
(NetWorker Client 7.5.1) using pipe. The problem is that the backup is unsuccessful, in the log file you can see the following message:
...
ERR
-24920,ERR_BACKUPOP: backup operation was unsuccessful
The backup tool failed with 0 as sum of exit codes.
External program terminated with exit code 1
DBMCLI returned error status E

But It seems that backups is done, only after some kind of check at the end NetWorker find errors!
On NetWorker 7.2 (which we had before) I did not see such error and it works OK even on lower versions of MaxDB (7.6, 7.3 (named SAPDB before)).

on NSR_ENV (/nsr/sapdb/env) there are parameters for NetWorker:
...
NSR_EXPIRE month
NSR_NOTVERBOSE RECOVER
NSR_EBIDTYPE NSAVETIME
NSR_USEOUTPUT SAVE
NSR_IGNOREERROR " unknown error 109 (0x6d)"
NSR_IGNOREERROR " using unlocked access"
NSR_SIZEROUNDUP LASTINTEGERS
...

I've changed parameter NSR_USEOUTPUT SAVE ---> NONE, made backup and it was done SUCCESSFULL, but this is not good solution for me because
the check at the end of backup is just ignored !!!

If someone using MaxDB with backup on NetWorker 7.5 without problem (or resolved it), I will respect his suggestion or advice.

Best regards,

Andrej