Announcement Banner
UNSOLVED

crisargentoIMI

updated

19 years ago

0

6767

May 25th, 2007 02:00

Oracle backup error

Below is the backup error we have encountered in one of our prod databases:

RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03006: non-retryable error occurred during execution of command:
backup
RMAN-07004: unhandled exception during command execution on channel c1
RMAN-10035: exception raised in RPC: ORA-27192: skgfcls: sbtclose2 returned err r - failed to close file
ORA-19511: nwora_session_close: savefile finish error
RMAN-10031: ORA-19583 occurred during call to DBMS_BACKUP_RESTORE.BACKUPPIECECR ATE

Explanation:

ORA-27192 skgfcls: sbtclose2 returned error - failed to close file

Cause: SBTCLOSE2 returned an error. This happens while closing a backup file during a backup or restore operation.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-19511: nwora_session_close: savefile finish error

Cause: An error occurred in the media management software which is linked with the Oracle server to perform backup and restore in cooperation with Recovery Manager.

Action: If the text of message 19511 does not provide enough information to resolve the problem, then you should contact the vendor of the media management software.

ORA-19511 errors originate with the media manager, not the oracle database.
the database merely
passes the message on from the media manager. the cause can only be addressed by the media management vendor.

Would like to seek your help in resolving this problem.

Thank you very much!

Cris
  • ble1

    6 Operator

    •

    14354 Posts

    •

    56186 Points

    2111

    0

    Posted May 25th, 2007 02:00

    For given time stamp, what do you have in logs on backup server end?
  • amediratta

    2 Intern

    •

    2014 Posts

    2111

    0

    Posted May 26th, 2007 23:00

    If you are sure you have done the configuration they way NMO needs, run sbttest - Oracle binary to see if that backs up to NW. Syntax would be sbttest /etc/hosts where /etc/hosts is a small file and if it works good it would end fast.

    You can also run sample RMAN Scripts to see what does it show as MML during execution. If it fails recheck library linking.
  • aman2yin

    5 Posts

    2111

    0

    Posted June 23rd, 2012 05:00

    Dear Expert ,

    I am getting following Error while taking backup

    networker 7.6.3 on winodws  nmo 5.1 on linux with oracle 10 g

     

    RMAN-00571: ===========================================================

    ORA-19559: error sending device command: NSR_ENV=(NSR_GROUP=gp_cc1,NSR_PARENT_JOBID=32902,NSR_SERVER=srv-nw-mas01,NSR_SAVESET_NAME=RMAN:\cc1_FULL)

    ORA-19557: device error, device type: SBT_TAPE, device name:

    ORA-27194: skgfdvcmd: sbtcommand returned error

    ORA-19511: Error received from media manager layer, error text:

    Unknown command key

    Recovery Manager complete.

    The backup process failed:

    RMAN exited with return code '1'.

    Exiting with error:

    RMAN exited with return code '1'.

    cc1: RMAN exited with return code '1'.

  • danag2

    20 Posts

    2111

    0

    Posted June 25th, 2012 06:00

    You have the syntax incorrect.

    You have this:

    NSR_ENV=(NSR_GROUP=gp_cc1,NSR_PARENT_JOBID=32902,NSR_SERVER=srv-nw-mas01,NSR_SAVESET_NAME=RMAN:\cc1_FULL)

    Should be this:

    parms='ENV=(NSR_GROUP=gp_cc1,NSR_PARENT_JOBID=32902,NSR_SERVER=srv-nw-mas01,NSR_SAVESET_NAME=RMAN:\cc1_FULL);