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Power surge on the USB port in Windows 10

Summary: Follow the guidelines below to resolve the error "Unknown USB Device needs more power than the port can supply" that may appear in Windows 10.

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Article Content


Symptoms

A Dell laptop system with Windows 10 Pro 64 installed may report the following error: "Power surge on the USB port - Unknown USB Device needs more power than the port can supply." If you expand the message, the following message appears: "Power surge on the USB port - A USB device has malfunctioned and exceeded the power limits of its hub port. You should disconnect the device."

Power surge on the USB port
Figure 1: Power surge on the USB port

Cause

USB device causing power surge message when plugged into USB port.

Resolution

  1. Initial troubleshooting should follow the on-screen directions:
    1. Disconnect all USB peripheral items, then Click the Reset button on the screen using the system touchpad and touchpad buttons.
    2. Once reset, it is recommended that you reboot the system then reconnect the USB device and see if the error recurs.
  2. If the issue persists, follow the steps below to run the Hardware Troubleshooter and test the USB port:
    1. Type cmd in the Windows search bar and press Enter to open a command prompt.
    2. Type msdt.exe -id DeviceDiagnostic and press Enter to open the Windows Troubleshooter 
    3. Click Hardware and Devices and select Next.
    4. Click Run the troubleshooter and choose to run the tool as an Administrator.
    5. Click Next and follow the on-screen instructions to complete the troubleshooting process.
  3. If no issues are found, then uninstall and reinstall all the USB controllers following the steps below:
    1. Disconnect the USB device from the computer.
    2. Press Windows Logo + R keys on the keyboard and type devmgmt.msc in the Run Command box and press Enter. This opens the Device Manager.
    3. Expand Universal Serial Bus Controllers.
    4. Right-click every device under the Universal Serial Bus Controllers section, and then click Uninstall to remove them one at a time.
    5. Restart the computer so that Windows reinstalls the USB controller drivers automatically.
    6. Now, plug in the USB device, and then check if that resolves the issue.
  4. If this issue continues to occur with a specific device, it is possible that the device is requiring more voltage or power than is available from the USB port being used. In this case, a USB Hub with its own dedicated power source is suggested. Connect the Powered USB hub to the system USB port and then connect the device to the powered USB hub.
  5. Run the Diagnostic Test on your USB Ports
    1. Browse to the Dell USB Diagnostics page and follow the prompts, to help identify, and fix issues with your computer.

Article Properties


Affected Product

Inspiron, Latitude, Vostro, XPS, Latitude E7450

Last Published Date

03 Jan 2024

Version

6

Article Type

Solution