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What to do is your system stops with Windows Bug Check (Bluescreen) 0x0000007F

Summary: Learn more about What to do is your system stops with Windows Bug Check

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Article Content


Symptoms

 

OS:                       Windows 8 (Core, Professional, Enterprise)

Version:               Either 32 or 64 bit versions

 

Symptom:             System stops with Windows Bug Check (Bluescreen) 0x0000007F

 

Issue:                   A kernel level driver is not allowed to handle the exception, or the driver has two consecutive failures (double fault) 

Caution: Kernel Mode Traps in most cases are caused by faulty drivers, and not the Operating System. First glance dump file analysis with Bluescreen View,  WhoCrashedMe and even Windows Debugger may not point to the correct cause, and  additional analysis is required!

Cause

Troubleshooting using Windows Debugger (WinDbg): 

1.       Open the minidump file in Windows Debugger

2.       At the command prompt type !analyze –v <Enter>

3.       Press CTRL-F and search for "STACK_TEXT" (without quotes)

 

This should bring you to the begin of the memory stack, and should read similar to the example below: 

STACK_TEXT: 

8df1b118 8c64de77 8df1b4a0 87ca29d8 00009280 Ntfs!NtfsLookupAllocation+0x15e

8df1b1bc 8c64dc95 8df1b4a0 8902c008 87ca29d8 Ntfs!NtfsPrepareSimpleBuffers+0x11b

8df1b1f8 8c64d02d 8902c008 87ca29d8 09280000 Ntfs!NtfsPrepareBuffers+0x5d

8df1d344 94c8448c 00000000 b0fe8bf0 8df1d3a0 BHDrvx86+0x7f0ce

                               

Scroll to the very last line of the Stack Text and look for the driver/module loaded:

8df1d344 94c8448c 00000000 b0fe8bf0 8df1d3a0 BHDrvx86+0x7f0ce

 

4.       Extract the file name, in this case BHDrvx86, and research in KCS, Bing, Google etc.

Caution: If the last line indicates a Windows driver/module (prefix nt!, ntfs!, filtrmgr!, drx!) move up one line in the stack until you find a driver/module without a prefix.

5.       After you identified the respective driver/product, verify it on Microsoft’s Windows Compatibility site for compatibility with Windows 8.

6.       Replicate the action that triggered the Bug Check, e.g. reboot, copy the same file the customer copied …

7.       Repeat the stack analysis until the issue is resolved

 

Resolution

Rename either the driver which caused the Bug Check, or uninstall the respective application/driver If the driver/application is not marked as compatible with Windows 8, educate the customer on the compatibility issue and provide the link to the Windows Compatibility site.

Article Properties


Affected Product

Operating Systems

Last Published Date

22 Apr 2021

Version

4

Article Type

Solution