SourceOne Discovery Manager Web : lorsque le récapitulatif de la recherche de collecte est imprimé, il n'affiche pas tous les dossiers dans la section « Exécutions ».

Résumé: Tous les dossiers affichés dans la section « Exécutions » ne sont pas imprimés lors de l’impression du récapitulatif de la recherche de collecte.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Si un utilisateur Web SourceOne Discovery Manager sélectionne une recherche de collecte impliquant un grand nombre de dossiers, accède à l’onglet « Summary », développe la section « Executions » et sélectionne le bouton « Print », la liste des dossiers sur la page d’impression est tronquée, qui était présente dans la section

« Executions ».Ce problème se produit lorsqu’un grand nombre de dossiers mappés sont sélectionnés pour la recherche de collecte.

Cause

Ce problème est dû à un défaut logiciel.

Résolution

Ce problème sera résolu dans les correctifs de SourceOne Discovery Manager après la version 7.2.SP12 (7.2.12.0021). Les kits dell EMC SourceOne Patch et Service Pack sont disponibles au téléchargement via https://www.dell.com/support/.
 

En attendant, la solution de contournement suivante peut être utilisée pour résoudre le problème :
  • Accédez au dossier dans lequel SourceOne Discovery Manager Web est installé et accédez au sous-dossier « \DiscoveryManagerWeb\Scripts\packages\DiscoveryManager ».
  • Copiez « all.js » dans un emplacement sûr en tant que sauvegarde.
  • Modifiez le fichier « all.js » et recherchez la section suivante :
 this._toPrintView();
            domStyle.set(content.domNode.id, "width", "80em");
 
  • Modifiez la section identifiée et remplacez « 80em » par « ». Voici un exemple :        
this._toPrintView();
domStyle.set(content.domNode.id, "width", "");
 
  • Enregistrez les modifications apportées au fichier « all.js » et fermez-le.
  • Démarrez l’invite de commande en tant qu’administrateur et exécutez «IISreset /noforce« command. »
 
 

Informations supplémentaires

Remarque :
  • Dans de rares cas, en raison d’un problème d’origine lié au cache du navigateur, il est recommandé de tester en mode « incognito » du navigateur ou à l’aide d’un autre ordinateur hôte.
  • Si le nombre de dossiers est très élevé et que l’utilisateur cherche à imprimer, la taille de papier par défaut « Lettre » ou « A4 » peut ne pas être suffisante pour prendre en charge tous les dossiers répertoriés sur la page récapitulatif, bien que la nouvelle fenêtre d’impression après le correctif affiche tous les dossiers. Dans ce cas, l’utilisateur doit sélectionner une grande taille de page, par exemple A3, ou utiliser des options qui permettent de réduire le contenu pour s’adapter à la taille de papier sélectionnée. Tous les paramètres des imprimantes et des pilotes ne permettent pas de réduire le contenu pour s'adapter à la taille de la page.

Produits concernés

SourceOne, SourceOne Discovery Manager, SourceOne Email Management
Propriétés de l’article
Numéro d’article: 000198667
Type d’article: Solution
Dernière modification: 02 juin 2025
Version:  7
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.