Web SourceOne Discovery Manager: Přehled vyhledávání kolekce po vytištění nezobrazí všechny složky v části "Executions".

Shrnutí: Při tisku souhrnu vyhledávání kolekce se nevytisknou všechny složky zobrazené v části "Executions".

Tento článek se vztahuje na Tento článek se nevztahuje na Tento článek není vázán na žádný konkrétní produkt. V tomto článku nejsou uvedeny všechny verze produktu.

Příznaky

Pokud webový uživatel nástroje SourceOne Discovery Manager vybere vyhledávání sady, které zahrnovalo velký počet složek, přejde na kartu "Summary", rozbalí část "Executions" a vybere tlačítko "Print". Seznam složek na tiskové stránce se zkrátí, který se nachází v části "Executions".

K tomuto problému dochází, když je pro vyhledávání kolekce vybrán velký počet mapovaných složek.

Příčina

Tento problém způsobuje vada softwaru.

Řešení

Tento problém bude vyřešen v opravách nebo ve verzích Aktualizace Service Pack nástroje SourceOne Discovery Manager po verzi 7.2.SP12 (7.2.12.0021). Sady oprav Dell EMC SourceOne Patch a Service Pack jsou k dispozici ke stažení prostřednictvím https://www.dell.com/support/.
 

Do té doby lze problém překonat pomocí následujícího zástupného řešení:
  • Přejděte do složky, kde je nainstalován nástroj SourceOne Discovery Manager Web, a přejděte do podsložky "\DiscoveryManagerWeb\Scripts\packages\DiscoveryManager".
  • Zkopírujte soubor "all.js" na bezpečné místo jako zálohu.
  • Upravte soubor "all.js" a vyhledejte následující část:
 this._toPrintView();
            domStyle.set(content.domNode.id, "width", "80em");
 
  • Upravte identifikovanou část a změňte hodnotu "80em" na "". Následuje příklad:        
this._toPrintView();
domStyle.set(content.domNode.id, "width", "");
 
  • Uložte změny v souboru "all.js" a zavřete jej.
  • Spusťte příkazový řádek jako správce a spusťte příkaz "IISreset /noforcePříkaz ".
 
 

Další informace

Poznámka:
  • Ve výjimečných případech se může uživatel mezipaměti prohlížeče setkat s původním problémem, proto se doporučuje otestovat jej v režimu "Incognito" prohlížeče nebo pomocí jiného hostitelského počítače.
  • V případě, že počet složek je velmi velký a uživatel chce tisknout, výchozí velikost papíru "Letter" nebo "A4" nemusí být dostatečná, aby odpovídala všem složkám uvedeným na stránce souhrnu, přestože nové tiskové okno po opravě zobrazuje všechny složky. V takových případech bude muset uživatel buď vybrat velkou velikost stránky, např. A3, nebo použít možnosti, které umožňují zmenšit obsah tak, aby odpovídal vybrané velikosti papíru. Ne všechny tiskárny a nastavení ovladačů umožňují zmenšení obsahu podle velikosti stránky.

Dotčené produkty

SourceOne, SourceOne Discovery Manager, SourceOne Email Management
Vlastnosti článku
Číslo článku: 000198667
Typ článku: Solution
Poslední úprava: 02 čvn 2025
Verze:  7
Najděte odpovědi na své otázky od ostatních uživatelů společnosti Dell
Služby podpory
Zkontrolujte, zda se na vaše zařízení vztahují služby podpory.