Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

Data Domain: A BMC failure has been detected | BMC is unresponsive.

Summary: The baseboard management controller (BMC a.k.a iDRAC on Dell PowerEdge based platforms) is an integrated controller that is embedded on the motherboard of a Data Domain (DD) system. The BMC manages the interface between system-management software and platform hardware. BMC has its own dedicated firmware and RAM. Sensors within the DD system report to the BMC on parameters such as temperature, cooling fan speeds, power status, voltages, and so forth. The BMC monitors the sensors and alerts if any of the parameters do not stay within preset limits, indicating a potential failure of the system. ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

If the BMC (or iDRAC) becomes unresponsive or reports to be faulty, then an associated alert is generated by the Data Domain (DD) system.
One of the following EventIDs is reported by the DD:
ENVIRONMENT-00019	LegacyBMCHangCritical: BMC module in the controller is unresponsive 		
ENVIRONMENT-00020	BMCHangCritical: BMC module in the controller is unresponsive		
ENVIRONMENT-00038	The system is being shut down. BMC is unresponsive	
ENVIRONMENT-00039	BMC failure has been detected		
The system may continue to operate as normal, but certain environment variables may be unavailable - e.g Temperature and other sensor readings.
In some instances, a system shutdown may be initiated.



Cause

Common Causes:
  • The BMC/iDRAC becomes unresponsive to services further up the stack.
  • Services within Data Domain Operating System (DDOS) lose comms to BMC.
  • BMC/iDRAC has stopped responding (HW or SW fault).
  • Component failure. 

Resolution

Always follow KB Data Domain: BMC/iDRAC Reset Procedure.
For Dell PowerEdge Platform based systems (DD3300, 6400, 9400, DD9900) a 'flea drain' reset may be required. See KB Data Domain: DD3300/DD6900/ DD9400/DD9900 Platform Flea Drain (BMC Reset) Procedure.

Article Properties


Affected Product

Data Domain, Data Domain, Integrated Data Protection Appliance Family

Product

PowerProtect Data Protection Appliance, Data Domain Deduplication Storage Systems, PowerProtect Data Protection Hardware

Last Published Date

28 Feb 2023

Version

4

Article Type

Solution