PowerStore: Unable to establish vCenter Server connection after STIG Enablement

Summary: Some systems may encounter a connection issue with vCenter after Security Technical Implementation Guide (STIG) enablement. This results in the inability to connect to vCenter or impacts existing connections. ...

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Symptoms

Post-STIG enablement, attempt to connect PowerStore to vCenter server fails with error "unable to connect to vCenter".

Screenshot from PowerStore Manager:
image.png

Cause

The VASA server certificate may not load into the keystore due to a timing issue, leading to failed connections on port 8443. This is because the certificate loading process is inadvertently linked to the admin password state, which changes after STIG enablement.

Resolution

  1. Enable STIG on PowerStore and then connectivity from vcenter photonOS run openssl against port 8443.
    -vcenter [ ~ ]# openssl s_client -connect <PowerStore_Cluster_IP>:8443

     If no certificate returns, proceed to the next steps.

  2. Change the admin password through the GUI.
  3. Start an SSH connection to the PowerStore clusterIP with the service user and restart the ControlPath (CP) container by running the following command:
    svc_container_mgmt restart CP
  4. Run openssl against port 8443 again. The VASA server certificate should now be visible.
  5. Re-try vCenter Server Connection

Affected Products

PowerStore
Article Properties
Article Number: 000225415
Article Type: Solution
Last Modified: 09 Sept 2025
Version:  4
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