NetWorker Service on a Linux client Does Not Start Because Timeout was Exceeded

Summary: NetWorker service on the client does not start because the timeout was exceeded.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker service on the client is not starting.

systemctl status reports a timeout.

# systemctl status networker.service
 networker.service - EMC NetWorker. A backup and restoration software package.
   Loaded: loaded (/opt/nsr/admin/networker.service; enabled; vendor preset: 
   Active: failed (Result: timeout) 
  Process: <PID> ExecStart=/opt/nsr/admin/networker.sh start (code=killed, 
Main PID: <PID> (code=exited, status=1/FAILURE)
systemctl start networker.service reports a timeout.
# systemctl start networker
Job for networker.service failed because a timeout was exceeded.

Cause

NetWorker copies a startup script called networker under /etc/init.d. There is also a startup script called networker.service created for systemd.

If both a systemd service unit and a init script exist with the same name, there may be a conflict. Systemd may be trying to manage the service using both methods, leading to a timeout.

Resolution

Procedure:

  1. Remove the NetWorker script from /etc/init.d.
# mv /etc/init.d/networker /tmp/networker
  1. Check if NetWorker is enabled.
# systemctl is-enabled networker.service
  1. Reboot the client.
  2. Check the service status.
# systemctl status networker.service

Note: If the issue is resolved after performing the above steps, delete the script from the location it was copied to. In this example rm -rf /tmp/networker
Article Properties
Article Number: 000269625
Article Type: Solution
Last Modified: 08 Feb 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.