NetWorker: Data nejsou k dispozici kvůli problémům s kvalitou v systému Windows Backup Server

Shrnutí: Data nejsou k dispozici kvůli problémům s řešením MQ na zálohovacím serveru.

Tento článek se vztahuje na Tento článek se nevztahuje na Tento článek není vázán na žádný konkrétní produkt. V tomto článku nejsou uvedeny všechny verze produktu.

Příznaky

  • Software serveru NetWorker je nainstalován na serveru Microsoft Windows.
  • Po nedávném upgradu serveru NetWorker začnou služby. u konzole nsrwatch a konzole NetWorker Management Console (NMC) se však nepodařilo zobrazit žádné zálohy a ruční spuštění zálohování se nezdaří.
  • Okno výstrah NMC a zpráva NMC gstd.raw:
Linux: /opt/lgtonmc/logs/gstd.raw
Windows: C:\Program Files\EMC NetWorker\Management\GST\logs\gstd.raw

ERROR generated: "Message bus unable to open socket connection to host 'BACKUP-SRV' on port 5672: a socket error occurred" in file "D:/views/nw/19.8/nsrwebui/modules/nsm/gstnsm.c" line #11364

NetWorker: Jak používat nsr_render_log

  • Port 5672 nebo 5671 nenaslouchá na serveru NetWorker:
nsrports -t localhost -p PORT
netstat -ano | findstr PORT

POZNÁMKA: Port 5672 je starší port bez protokolu SSL. Port 5671 se používá pro protokol SSL. V systému NetWorker 19.7.x a novějších je port 5672 zakázán a provoz ve službě Thunderbolt se odesílá přes port 5671.
  • Spuštěním příkazu spusťte server cmd, a jedná se o výstup:
Configuring logger redirection
Logger - error: {removed_failing_handler,rabbit_log}
13:46:52.589 [error] Error in process <0.206.0> on node rabbit_prelaunch_3804@localhost with exit value:
{eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]}
13:46:52.589 [error] Supervisor inet_gethost_native_sup had child at module inet_gethost_native at <0.206.0> exit with reason {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]} in context child_terminated
13:46:52.589 [error] gen_server inet_gethost_native_sup terminated with reason: {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]}
13:46:52.589 [error] CRASH REPORT Process inet_gethost_native_sup with 0 neighbours exited with reason: {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]} in gen_server:handle_common_reply/8 line 805
13:46:52.589 [error] Supervisor kernel_safe_sup had child inet_gethost_native_sup started with {inet_gethost_native,start_link,undefined} at <0.205.0> exit with reason {eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]} in context child_terminated
13:46:52.605 [error] Error in process <0.206.0> on node rabbit_prelaunch_3804@localhost with exit value:
{eacces,[{erlang,open_port,[{spawn,"inet_gethost 4 "},[{packet,4},eof,binary]],[{file,"erlang.erl"},{line,2258}]},{inet_gethost_native,server_init,2,[{file,"inet_gethost_native.erl"},{line,184}]}]}
13:46:52.636 [error] 

13:46:52.636 [error] BOOT FAILED
BOOT FAILED
13:46:52.636 [error] ===========
===========
13:46:52.636 [error] ERROR: epmd error for host BACKUP-SRV: {could_not_start_server,inet_gethost_native} (unknown POSIX error)
ERROR: epmd error for host BACKUP-SRV: {could_not_start_server,inet_gethost_native} (unknown POSIX error)
13:46:52.636 [error] 

13:46:53.647 [error] Supervisor rabbit_prelaunch_sup had child prelaunch started with rabbit_prelaunch:run_prelaunch_first_phase() at undefined exit with reason {epmd_error,"BACKUP-SRV",{could_not_start_server,inet_gethost_native}} in context start_error
13:46:53.647 [error] CRASH REPORT Process <0.151.0> with 0 neighbours exited with reason: {{shutdown,{failed_to_start_child,prelaunch,{epmd_error,"BACKUP-SRV",{could_not_start_server,inet_gethost_native}}}},{rabbit_prelaunch_app,start,[normal,[]]}} in application_master:init/4 line 138
{"Kernel pid terminated",application_controller,"{application_start_failure,rabbitmq_prelaunch,{{shutdown,{failed_to_start_child,prelaunch,{epmd_error,\"BACKUP-SRV\",{could_not_start_server,inet_gethost_native}}}},{rabbit_prelaunch_app,start,[normal,[]]}}}"}
Kernel pid terminated (application_controller) ({application_start_failure,rabbitmq_prelaunch,{{shutdown,{failed_to_start_child,prelaunch,{epmd_error,"BACKUP-SRV",{could_not_start_server,inet_gethost

Crash dump is being written to: erl_crash.dump...done

Příčina

K tomuto problému může dojít, pokud v kořenovém adresáři svazku, kde je nainstalován netWorker, existuje falešný soubor nebo adresář s názvem "program". Tento soubor nebo adresář může být skrytý.

Řešení

Zjistěte, zda v kořenovém adresáři libovolného svazku existuje soubor nebo adresář s názvem "program". Pokud ano, odstraňte nebo přejmenujte soubor nebo adresář:
  1. Otevřete příkazový řádek pomocí příkazu Spustit jako správce.
  2. Přejděte do kořenového adresáře svazku.
Příklad:
cd D:\
  1. Spuštěním následujícího příkazu zobrazíte objekty, včetně skrytých objektů.
dir /a
  1. Pokud je nalezen program, objekt odstraňte nebo přejmenujte.
  2. Opakujte kroky 1–4 pro všechny ostatní svazky nebo písmena jednotek.
  3. Restartujte službu
net stop nsrexecd /y
net start nsrd
Pokud je konzole NMC nainstalována ve stejném systému:
net start gstd
  1. Při další příležitosti restartujte hostitele.

Dotčené produkty

Data Protection, NetWorker Family, NetWorker, NetWorker Management Console

Produkty

NetWorker Management Console
Vlastnosti článku
Číslo článku: 000220828
Typ článku: Solution
Poslední úprava: 09 říj 2024
Verze:  3
Najděte odpovědi na své otázky od ostatních uživatelů společnosti Dell
Služby podpory
Zkontrolujte, zda se na vaše zařízení vztahují služby podpory.