NetWorker: nelze vytvořit klienta v NMC "nelze určit název adresy null"
Shrnutí: Nelze vytvořit klienta pomocí Průvodce novým klientem v konzoli NMC.
Příznaky
Při pokusu o vytvoření nového klienta v konzoli NetWorker Management Console (NMC) se zobrazí následující zpráva:
Connecting to host client_name failed: The host reports: Unable to create a session channel with nsrexecd on host client_name to execute the command ‘nsrfsra’: Unable to determine the name of address ‘null’ — Hostname.
Příčina
nsrexecd_nsrfa Poskytuje funkci vzdáleného přístupu k souborům, kterou používá server NetWorker, když potřebuje komunikovat s klientem při operacích zahrnujících načítání souborů a metadat napříč RPC.
Nelze vytvořit kanál pro vzdálený přístup k souborům pomocí nsrexecd .
Možné důvody:
- Chybné DNS / zpětné vyhledávání
- Služba nsrexecd klienta není spuštěna.
- Neshoda rozsahu portů
Také v případě, že soubor serverů v rozlišení obsahuje chybnou položku:
- Poškozen
- Obsahuje starý název serveru,
- Obsahuje duplicitní záznamy,
- V souboru serverů obsahuje nesprávné položky názvu hostitele nebo DNS.
- Formát souboru serveru je poškozený.
Řešení
Chcete-li tuto chybu vyřešit, je třeba provést následující kontroly a akce:
- Ověření překladu IP adres a komunikace
- Ujistěte se, že překlad IP adres funguje správně v obou směrech: Server → Client a Client → Server pomocí '
nslookup' a potvrďte, že se každý název hostitele správně přeloží - Ověřte požadované porty: Ověřte, zda jsou mezi serverem a klientem dostupné povinné porty služby NetWorker 7937 a 7938 .
- Ujistěte se, že překlad IP adres funguje správně v obou směrech: Server → Client a Client → Server pomocí '
Na serveru NetWorker i v klientovi NetWorker použijte příkaz nsrports Příkaz k ověření překladu IP adres a komunikace portů 7937 a 7938:
nsrports -t HOSTNAME -p PORT
Příklad výstupu:
[root@nsr ~]# nsrports -t rhel-client01.amer.lan -p 7937 Forward lookup for rhel-client01.amer.lan Query time: 0.001 sec Canonical name (CNAME): rhel-client01.amer.lan Address (A): 192.168.9.121 Connect to port 7937: Succeeded (0.001 sec) Reverse lookup for 192.168.9.121 Query time: 0.001 sec Name: rhel-client01.amer.lan
Další informace naleznete zde: NetWorker: Jak používat příkaz nsrports
- Ujistěte se, že server NetWorker vidí
nsrexecd_nsrfaV klientovi NetWorker:
nsrrpcinfo -p CLIENT_NAME
[root@nsr ~]# nsrrpcinfo -p rhel-client01.amer.lan PROGRAM VERSION PROTOCOL PORT SERVICE 100000 2 tcp 7938 nsrportmapper Port Mapper 100000 2 udp 7938 nsrportmapper Port Mapper 390436 1 tcp 8359 nsrexecd GSS Authentication 390435 1 tcp 9613 nsrexecd Resource Mirror 390113 1 tcp 7937 nsrexecd Remote Execution 390440 1 tcp 8942 nsrexecd_nsrfa Remote File Access
- Pokud server nevidí v klientovi nsrexecd nebo nsrexecd_nsrfa, proveďte v klientském systému následující akce:
- Ověřte, zda je spuštěna služba klienta:
- Linux:
ps -ef | grep nsr - Windows:
sc query nsrexecd
- Pokud klient není spuštěný, pokuste se spustit služby:
- Linux:
systemctl start networker - Windows:
net start nsrexecd
daemon.raw Pro chyby v případě, že se služba nespustí:
- Linux:
/nsr/logs/daemon.raw - Windows (výchozí):
C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw - NetWorker: Jak pomocí nsr_render_log vykreslit .raw soubory protokolu
- Pokud jsou spuštěny klientské služby, zkontrolujte, zda
nsrexecd_nsrfaběží.
- Pokud je v klientovi nainstalován software "rozšířeného klienta", můžete se obrátit na
nsrrpcinfo -p localhost. Tento příkaz by měl zobrazit obě možnostinsrexecdansrexecd_nsrfaSpuštění. SkriptnsrrpcinfoPříkaz není k dispozici v systémech, které mají nainstalovaný pouze standardní klientský balíček. - Pokud klient nemá nainstalovaný rozšířený klientský software, zobrazí se pouze
nsrexecdspuštěné s příkazy OS, neuvidítensrexecd_nsrfa. Pokud se zobrazí možnost Ověřte ze serveru NetWorker,nsrexecd_nsrfanaslouchání na klientovi (viz krok 2).
-
- Zkontrolujte rozsah portů NetWorker použitý v klientovi pomocí
nsrports. Výchozí rozsah portů je 7937–9936. Viz: NetWorker: Jak pomocí příkazu "nsrports -s" změnit rozsah portů služby NetWorker
- Zkontrolujte rozsah portů NetWorker použitý v klientovi pomocí
- Zkontrolujte, zda má klient ve složce "res" soubor "servers":
-
- Linux:
/nsr/res - Windows (výchozí):
C:\Program Files\EMC NetWorker\nsr\res
- Linux:
-
- Pokud existuje soubor serverů, musí být splněna jedna z následujících podmínek:
-
- Buď by měl být prázdný (povoleny všechny servery)
- Pokud jsou v souboru definovány servery, musí být v souboru definován server NetWorker, ze kterého jste se pokusili přidat tohoto klienta.
-
- Pokud se souborem nejsou žádné zjevné problémy, je možné, že se poškodil. Přejmenujte soubor a restartujte služby:
-
- Linux:
systemctl restart networker - Windows:
net stop nsrexecd && net start nsrexecd
- Linux:
Po provedení všech výše uvedených kroků ověření zkuste přidat klienta na server NetWorker.