Avamar VMware-Image-Backupperformance ist langsam (LÖSUNGSPFAD)

Zusammenfassung: Ein Artikel zur Diagnose einer langsamen Backupperformance von Backups auf Avamar-VMware-Image-Ebene.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Die Ausführung eines Image-Backups einer Avamar Virtual Machine nimmt viel Zeit in Anspruch und es tritt vor dem Ende des Backupzeitfensters ein Timeout auf.

Langsam ausgeführte Image-Backups verursachen einen Engpass auf dem Proxy, wenn der Pool von Image-Proxys, die für die Wartung von VM-Clients verfügbar sind, nicht ausreicht.

Dies führt zu Warteschlangen, während die verbleibenden VM-Clients auf einen Proxy warten, der sie bedient.

Ursache

Es gibt viele Faktoren, die dazu führen können, dass VM-Image-Backups langsam ausgeführt werden oder lange dauern. Lesen Sie die folgenden Artikel, in denen bekannte Probleme im Zusammenhang mit dieser Art von Verhalten dokumentiert sind.

Lösung

Schritt 1: Holen Sie alle "erforderlichen" Informationen vom Kunden ein.
Es ist wichtig, ein detailliertes Verständnis der Umgebung zu haben, bevor Sie mit der Fehlerbehebung beginnen. Erfassen Sie Folgendes:

Achten Sie außerdem auf Folgendes:

  • Die verwendete Version von vCenter
  • Die verwendete Version des Proxyclients

Schritt 2: Sammeln Sie Protokolle für das Image-Backup.

Schritt 3: Bekannte Probleme überprüfen.
Informationen zu häufigen Problemen finden Sie im Abschnitt "Troubleshooting" des Avamar for VMware-Benutzerhandbuchs. Überprüfen Sie als Nächstes Folgendes:

  • Überprüfen Sie, ob CBT für die VM aktiviert ist.

Weitere Informationen finden Sie in den folgenden VMware-Artikeln: 

  • Broadcom VMware-Artikel 1020128 Changed Block Tracking (CBT) auf virtuellen Maschinen

 

  • f)Werden CBT-Image-Backups aufgrund des Problems im VMware KB-Artikel 2145895 als vollständige Backups ausgeführt? 

Schritt 4: Wenn das Problem weiterhin besteht, nachdem die oben genannten Probleme behoben wurden, eskalieren Sie zur nächsten Supportstufe.

Weitere Informationen

VM-Image-Backups funktionieren anders als herkömmliche Avamar-Backups, bei denen der Avamar-Agent als Gastservice innerhalb des Betriebssystems installiert wird.

Während eines herkömmlichen Dateisystembackups scannt der Prozess "avtar" das Datenvolumen und verarbeitet alle Dateien, die als neu oder geändert erkannt werden. Die für das Backup benötigte Zeit ist proportional zur Anzahl der Dateien im Datenvolumen PLUS der kombinierten Größe aller geänderten Dateien.

Eine ausführliche Erörterung dieses Verhaltens finden Sie unter:

Bei VM-Image-Backups mountet der Proxy die virtuellen Laufwerke des Clients. Avtar verarbeitet Speicherblöcke statt Dateien

Wenn die VMware-Funktion "Changed Block Tracking" (CBT) für die VM aktiviert ist, werden nur Blöcke verarbeitet, die geänderte Daten enthalten. Dies minimiert die zu verarbeitenden Daten und reduziert den Ressourcenverbrauch.  

Dies verbessert die Leistung für Clients mit Millionen von Dateien bei einer niedrigen Änderungsrate drastisch.

Weitere Informationen finden Sie im Avamar for VMware – Benutzerhandbuch:

Betroffene Produkte

Avamar

Produkte

Avamar, Avamar Client, Avamar Client for VMware
Artikeleigenschaften
Artikelnummer: 000041062
Artikeltyp: Solution
Zuletzt geändert: 07 Okt. 2025
Version:  7
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