PowerPath für Windows: PowerPath meldet Ereignis 4 – Quelle: Powerpath – EMC Powerpath-Fehler: MPAPI : Fehler: Es ist ein interner Fehler aufgetreten.

Zusammenfassung: Ereignis 4 wird im Viewer angezeigt und meldet einen PowerPath-MPAPI-Fehler der Corporation () nach dem Upgrade auf 5.7 SP2. MPAPI (Powermt, Host-Agent, Powermig) verursacht Fehler. Keine Auswirkungen auf das PowerPath-Cluster. ...

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome



PowerPath für Windows

PowerPath meldet Ereignis 4 – Quelle: Powerpath – EMC PowerPath-Fehler: MPAPI : Fehler: Es ist ein interner Fehler aufgetreten.

Dieses Ereignis wird stündlich in der Windows-Ereignisanzeige gemeldet.
Obwohl das Ereignis stündlich gemeldet wird, gibt es keine Probleme mit der PowerPath- und Cluster-Funktionalität.
Das Ereignis trat nach dem Upgrade von PowerPath von 5.5 auf 5.7 SP2 auf.

Ursache

Clients für MPAPI sind Powermt, der Host-Agent-Service und der Powermig-Service, wodurch das Ereignis in der Ereignisanzeige auftritt.

Lösung

Deaktivieren Sie die Funktion zur automatischen Hostregistrierung und prüfen Sie, ob das Problem behoben ist.
Um die automatische Hostregistrierung zu deaktivieren, reparieren Sie PowerPath mithilfe der CLI, wenn die PowerPath-Version 5.7 SP4 oder früher ist: 
C:\EMCPower.X64.signed.5.7.SP2.bxxx.exe /s /v"/L*v C:\logs\PPrepair.log REINSTALL=ALL AUTO_HOST_REGISTRATION=0 NO_REBOOT=1"

In PowerPath 6.0 kann die automatische Hostregistrierung mit dem Befehl powermt deaktiviert werden:
powermt set auto_host_registration={on|off} 

Wenn das Problem weiterhin besteht, aktualisieren Sie PowerPath auf 6.0 oder höher, da die DLLs während des Upgrades möglicherweise inkonsistent werden und dieses Problem bei PowerPath 6.0 nicht auftreten sollte.

Weitere Informationen

Siehe OPT-467881.

Betroffene Produkte

Storage Networking
Artikeleigenschaften
Artikelnummer: 000055944
Artikeltyp: Solution
Zuletzt geändert: 10 Dez. 2025
Version:  5
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.