ECS: Evi Arama: ObjectGCObjectCleanup - Symptom Code: 1313 ve 1314

Zusammenfassung: Bu, ECS 3.2.1.0 da bulunan ve bellek kartlarını akıllı sistem kartlarında bulunan ve bellek kartlarını Uyarı.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Bir ECS, aşağıdaki uyarıyı vererek evi aradı.
Açıklama: CAS İşleme nesnesi temizleme hızı yavaş.
 
Belirti Kodu Önem Derecesi
1313 UYARI
1314 ERROR

Örnek uyarı:
<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
    xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <TransType>10</TransType>
    <TransTypeDesc>EventXML</TransTypeDesc>
    <TransID>0</TransID>
    <Node Status="Unknown" State="Unknown" ID="ECSQE00079">
        <Identifier>
            <DeviceState>1</DeviceState>
            <DeviceStatus>1</DeviceStatus>
            <ClarifyID>ECSQE00079</ClarifyID>
            <SiteName>UNKNOWN</SiteName>
            <Vendor>EMC</Vendor>
            <DeviceType>ElasticCloudStorageApp</DeviceType>
            <Model>ElasticCloudStorage</Model>
            <SerialNumber>ECSQE00079</SerialNumber>
            <WWN>ECSQE00079</WWN>
            <Platform>platform</Platform>
            <OS>SLES</OS>
            <OS_VER>12.3</OS_VER>
            <UcodeVer>3.3.0.0-4349.d0de882</UcodeVer>
            <EmbedLevel>2</EmbedLevel>
            <InternalMaxSize>512800</InternalMaxSize>
            <Comment>Object Alert</Comment>
        </Identifier>
        <Connection>
            <ConnectType>ESRS</ConnectType>
            <IPName>austin-burlywood.ecs.lab.emc.com</IPName>
            <ConnectNum>169.254.109.16</ConnectNum>
            <Port>22</Port>
        </Connection>
        <HeartBeat>
            <HBStatus></HBStatus>
            <HBState></HBState>
        </HeartBeat>
        <InternalData>
            <FileList/>
            <EventList>
                <Event>
                    <SymptomCode>1314</SymptomCode>
                    <Category>Configuration</Category>
                    <Severity>Error</Severity>
                    <Status>Unknown</Status>
                    <Component>Object</Component>
                    <ComponentID></ComponentID>
                    <SubComponent>CAS Processing Object Cleanup</SubComponent>
                    <SubComponentID></SubComponentID>
                    <CallHome>true</CallHome>
                    <FirstTime>2019-01-28T22:15:30.182Z</FirstTime>
                    <LastTime>2019-01-28T22:15:30.182Z</LastTime>
                    <Count>0</Count>
                    <EventData><![CDATA[]]></EventData>
                    <Description><![CDATA[CAS Processing object cleanup speed is slow.  [Ref_ID : ObjectGCObjectCleanup]]]></Description>
                </Event>
            </EventList>
        </InternalData>
        <ExternalFiles/>
    </Node>
</ConnectHome>

Ursache

ECS'de eski işlenmemiş CAS GC Nesne Temizleme görevleri vardır ve bu, yavaş CAS GC uyarısını tetikleyebilir.

Lösung

Not: 3.5'ten küçük ECS sürümlerinde, herhangi bir silme işlemi gerçekleşmezse bu sensör için uyarıya neden olan bir sorun vardır. Geri alınacak yer olmasa bile. 

ECS'deki düğümlerden birine SSH üzerinden bağlanın.
  1. Mevcut sensör durumunu doğrulayın:
# svc_rest_cmd /vdc/sensor/status/ObjectGCObjectCleanup
Örneğin:
#  svc_rest_cmd /vdc/sensor/status/ObjectGCObjectCleanup
svc_rest_cmd 1.0.10

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
  <SensorId>ObjectGCObjectCleanup</SensorId>
  <ListSensorStatus>
    <SensorStatusRestRep>
      <ContextId>ObjectGCObjectCleanup</ContextId>
      <CurrentState>OK</CurrentState>
      <NodeId>1f4368c3-37cd-467f-9efc-289264806ea0</NodeId>
      <PreviousState>OK</PreviousState>
      <Time>1551118064264</Time>
    </SensorStatusRestRep>
  </ListSensorStatus>
<SensorStatusList>
<Tamam olarak ayarlanmışsa CurrentState'i> arayın, bu hatanın etkin olmadığı anlamına gelir ve SR'yi kapatabilirsiniz. CurrentState <> iyi durumda değilse (Uyarı veya Hata) sorun giderme işlemine devam edin.
 
  1. CAS GC'nin etkin olup olmadığını, Nesnenin etkin olup olmadığını ve dry_run false olarak ayarlanıp ayarlanmadığını kontrol edin
Komut:
# svc_param list com.emc.ecs.objectgc | grep -e cas.enabled -e dry_run -e object.enabled
Örneğin:
com.emc.ecs.objectgc.cas.enabled                                   Enable or disable CAS GC                                       true
com.emc.ecs.objectgc.cas.process_object.dry_run                    If enabled then delete marker insertion will be skipped a...   *false
com.emc.ecs.objectgc.cas.process_object.enabled                    Enable or disable GC process object                            true
Yapılandırma değerleriniz yukarıdakilerle eşleşmiyorsa bir SR açın ve bu KB makalesine başvurun.

Weitere Informationen

YANSIMALAR:
CAS GC, silme klipleriyle ilişkili blobları geri alır (Yansımalar olarak da adlandırılır). ECS'de hem klipler hem de bloblar nesne olarak kabul edilir. Bir klip silindiğinde, silme çağrısının ne zaman ve hangi IP'den yapıldığı gibi denetim bilgilerini tutan bir yansıma haline gelir.
Bazı Uygulamalar bu bilgileri sonsuza kadar saklar. Tipik klip veya yansıma boyutu KB cinsindendir, bu nedenle yansımalar tarafından çok fazla alan tüketilmez. 

Yansımaları da geri almayı tercih ederseniz, CAS grubu için Yansıma Süre Sonu ayarlamaları gerekir.
Bu işlem, ECS arayüzünden (Grupları Yönet >>, Ad alanını seçin ve Kovayı Düzenle'ye tıklayın.   Gerekli sekmesine gidin ve Yansıma Sona Erme Süresi'ni etkinleştirin ve Yansıma Yaşı'nıayarlayın.

Bir CAS kovasını silmek için yansımaların süresinin dolması gerekir çünkü bunlar hala kovadaki nesneler olarak kabul edilir.

Betroffene Produkte

ECS, ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Appliance Hardware Gen1 U-Series, ECS Appliance Hardware Gen1 C-Series, ECS Appliance Hardware Gen2 C-Series, Elastic Cloud Storage

Produkte

ECS Appliance Hardware Gen3 EX300, ECS Appliance Hardware Gen3 EX3000, ECS Appliance Hardware Gen2 D-Series, ECS Appliance Hardware Gen2 U-Series, ECS Appliance Hardware Gen3 EX500, ECS Appliance Hardware Gen3 EXF900, ECS Appliance Hardware Series , ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, Elastic Cloud Storage ...
Artikeleigenschaften
Artikelnummer: 000061341
Artikeltyp: Solution
Zuletzt geändert: 17 Dez. 2025
Version:  11
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.