AppSync: Der Serviceplan schlägt fehl oder zeigt bei der Bearbeitung einen Fehler an: "VPLEXClientFactory – could not obtain lock within 5000/10000MILLISECONDS"

Zusammenfassung: Ein Serviceplan, der VPLEX umfasst, kann mit folgendem Fehler fehlschlagen: "VPLEXClientFactory - could not obtain lock within 5000MILLISECONDS/10000MILLISECONDS". Außerdem wird beim Bearbeiten des Serviceplans und in der Phase zum Erstellen einer Kopie beim Auswählen des VPLEX-Clusters der Fehler wie oben angezeigt. ...

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Der Serviceplan schlägt fehl oder beim Bearbeiten der Serviceplaneinstellungen werden Fehler angezeigt. Der Fehler ist wie folgt:

Für Kunden mit AppSync 4.1.0.x lautet der Fehler:

concurrent access timeout on VPLEXClientFactory - could not obtain lock within 5000MILLISECONDS

Für Kunden mit AppSync 4.2.0.x lautet der Fehler:

concurrent access timeout on VPLEXClientFactory - could not obtain lock within 10000MILLISECONDS

AppSync-Serverprotokolle zeigen den folgenden Fehler an:

<DATE & TIME> ERROR [default task-38] [org.jboss.as.ejb3.invocation] [AppSync Server] [] WFLYEJB0034: EJB Invocation failed on component VPLEXClientFactory for method public com.emc.archway.service.vplex.VPLEXClient com.emc.archway.service.vplex.VPLEXClientFactory.getClient(com.emc.archway.context.ExecutionContext,com.emc.archway.objectmodel.storage.vplex.VPLEXManagementServer) throws com.emc.archway.errorMessages.ArchwayException: javax.ejb.ConcurrentAccessTimeoutException: WFLYEJB0241: EJB 3.1 PFD2 4.8.5.5.1 concurrent access timeout on VPLEXClientFactory - could not obtain lock within 10000MILLISECONDS

 

Ursache

Die VPLEX-Antwort wird nicht innerhalb des hartcodierten Timeouts von AppSync empfangen.

Dies scheint ein Problem mit der VPLEX-Leistung zu sein. An einem bestimmten Punkt reagiert VPLEX nur langsam und AppSync kann den VPLEX-Client nicht innerhalb des hartcodierten Timeout-Fensters von 5 oder 10 Sekunden abrufen. Dies führt dazu, dass der Serviceplan fehlschlägt.

Der Grund für den Fehler beim Bearbeiten des Serviceplans ist auch, dass AppSync versucht, VPLEX-Informationen neu zu erkennen, bevor sie auf der Benutzeroberfläche angezeigt werden, und aufgrund eines VPLEX-Performanceproblems eine Zeitüberschreitung auftritt.

Dieses Timeout ist in AppSync 4.1 und 4.2 vorhanden.

AppSync 4.1.0.x hat einen Timeoutwert von 5.000 MILLISEKUNDEN (5 Sekunden).
AppSync 4.2.0.x hat einen Timeout-Wert von 10.000 MILLISEKUNDEN (10 Sekunden).

 

Lösung

Führen Sie ein Upgrade auf AppSync 4.3 oder höher durch, bei dem die Timeout-Prüfung entfällt.

 

Produkte

AppSync
Artikeleigenschaften
Artikelnummer: 000193937
Artikeltyp: Solution
Zuletzt geändert: 31 Okt. 2025
Version:  3
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.