Data Domain: O BoostFS entra em pane ou o ponto de montagem não responde

Zusammenfassung: O BoostFS entra em pane ou trava ou o ponto de montagem não responde quando o aplicativo de backup executa operações de E/S no ponto de montagem do BoostFS.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Sintomas:

  • O BoostFS trava e entra em pane aleatoriamente. Isso acontece quando a carga de trabalho é alta.
  • O aplicativo de backup atrasa o desempenho READ e WRITE operações no ponto de montagem do BoostFS.
  • Quando há atrasos na READ e WRITE operações do aplicativo de backup, logs do BoostFS mostram isso error 5057 File handle is stale from Data Domain server.

Logs do BoostFS:

###### WRITE operation FAILED due to STALE FILE HANDLE error ######
Sep 11 00:36:29.635 7884 10740 [E] [ddp log] [1ECC:29F4] ddcl_ddcp_send_file_loop: Call to recv
refs2 failed. [ERR=5057] Sep 11 00:36:29.635 7884 10740 [E] [ddp log] [1ECC:29F4] ddcl_ddcp_pwrite: Call to send file loop2 failed. [ERR=5057]
Sep 11 00:36:29.635 7884 10740 [E] [ddp log] [1ECC:29F4] ddcl_ddcp_pwrite: Error in ddcl ddcp
pwrite. [ERR=5057] Sep 11 00:36:29.635 7884 10740 [E] [ddp log] [1ECC:29F4] ddp_write() failed Offset 11010048, BytesToWrite 1048576, BytesWritten 0 Err: 5057-File handle is stale
Sep 11 00:36:29.635 7884 10740 [E] bfs_cache_flush: failed: 5057 File handle is stale (0 bytes written)
Sep 11 00:36:29.651 7884 11292 [E] [ddp log] [1ECC:2C1C] ddcl_ddcp_send_file_loop: Call to recv
refs2 failed. [ERR=5057]
####### PANIC occurred HERE #######
Sep 11 00:36:29.667 7884 11292 [E] [ddp log] [1ECC:2C1C] PANIC: ..\ddcl\ddcl_ddcp.c:
ddcl_ddcp_commit: 4541: !(c->send_offset == c->write_offset)

Separação:

  1. Verifique os logs do BoostFS e do DDFS no servidor para ver o erro relatado acima.
  2. Observe a demora em READ e WRITE Operações do aplicativo de backup. Considere os registros de entrada e saída da API do BoostFS.
  3. Verifique o valor definido para OST_ABANDON_TIMEOUT (padrão de três horas).
  4. Verifique se o tempo de espera excedido da RPC é maior do que o valor definido para OST_ABANDON_TIMEOUT.

Ursache

  1. O problema se deve a um atraso no READ e WRITE Operações pelo aplicativo de backup. Isso aciona o DDFS para descartar o tempo de espera excedido. Isso leva ao fechamento do identificador de arquivo correspondente após três horas (valor padrão)
  2. Esse é o período de tempo de espera excedido padrão de descarte usado pelo DDFS para identificar o identificador de arquivo inativo. Eventualmente, novas gravações podem apresentar pane no lado do client.

Lösung

Entre em contato com o Suporte Dell para aumentar o tempo de espera excedido, que requer acesso ao bash.

Altere o OST_ABANDON_TIMEOUT no lado do servidor usando as etapas abaixo. Seu valor pode ser definido para um valor maior com, no máximo, 12 horas.

 

Nota: O file system deve ser desativado e ativado como parte da aplicação da solução.

 

  1. Faça login no Data Domain com acesso à função de administrador . O suporte entra no modo bash e, em seguida, entra se Modo com ddsh -s
  2. Verifique o original OST_ABANDON_TIMEOUT Valor.
SE@dd## se sysparam show OST_ABANDON_TIMEOUT
  1. Aumente o OST_ABANDON_TIMEOUT Valor. Por padrão, o valor é 10800 (três horas).
SE@dd## se sysparam set OST_ABANDON_TIMEOUT=129600
SE@dd## se sysparam show OST_ABANDON_TIMEOUT

Name Description Current Default Override
------------------- --------------------------------- ------- ------- -----
---
OST_ABANDON_TIMEOUT DDCP abandon context timeout(sec) 129600 10800 rpc
------------------- --------------------------------- ------- ------- -----
---

SE@dd##priv set admin
  1. Reinicie o file system após a alteração do parâmetro acima. Confirme com o cliente se essa reinicialização é permitida. Caso contrário, agende um período de manutenção para executar o seguinte comando:
SE@dd## filesys disable
SE@dd## filesys enable

Betroffene Produkte

Data Domain
Artikeleigenschaften
Artikelnummer: 000215706
Artikeltyp: Solution
Zuletzt geändert: 14 Jan. 2026
Version:  4
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.