Data Domain: BoostFS får panik eller monteringspunkten svarar inte
Zusammenfassung: BoostFS får panik eller kraschar, eller så svarar monteringspunkten inte när säkerhetskopieringsprogrammet utför I/O-åtgärder på BoostFS-monteringspunkten.
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
Symptom:
- BoostFS kraschar och får panik slumpmässigt. Detta inträffar när arbetsbelastningen är hög.
- Säkerhetskopieringsprogrammet utförs fördröjt
READochWRITEåtgärder på BoostFS-monteringspunkten. - När det finns förseningar i
READochWRITEåtgärder från säkerhetskopieringsprogrammet visar BoostFS-loggarna dettaerror 5057 File handle is stale from Data Domain server.
BoostFS-loggar:
###### WRITE operation FAILED due to STALE FILE HANDLE error ###### Sep 11 00:36:29.635 7884 10740 [E] [ddp log] [1ECC:29F4] ddcl_ddcp_send_file_loop: Call to recv refs2 failed. [ERR=5057] Sep 11 00:36:29.635 7884 10740 [E] [ddp log] [1ECC:29F4] ddcl_ddcp_pwrite: Call to send file loop2 failed. [ERR=5057] Sep 11 00:36:29.635 7884 10740 [E] [ddp log] [1ECC:29F4] ddcl_ddcp_pwrite: Error in ddcl ddcp pwrite. [ERR=5057] Sep 11 00:36:29.635 7884 10740 [E] [ddp log] [1ECC:29F4] ddp_write() failed Offset 11010048, BytesToWrite 1048576, BytesWritten 0 Err: 5057-File handle is stale Sep 11 00:36:29.635 7884 10740 [E] bfs_cache_flush: failed: 5057 File handle is stale (0 bytes written) Sep 11 00:36:29.651 7884 11292 [E] [ddp log] [1ECC:2C1C] ddcl_ddcp_send_file_loop: Call to recv refs2 failed. [ERR=5057] ####### PANIC occurred HERE ####### Sep 11 00:36:29.667 7884 11292 [E] [ddp log] [1ECC:2C1C] PANIC: ..\ddcl\ddcl_ddcp.c: ddcl_ddcp_commit: 4541: !(c->send_offset == c->write_offset)
Prioritering:
- Kontrollera BoostFS- och DDFS-loggarna på serversidan för felet som rapporteras ovan.
- Observera fördröjningen i
READochWRITEåtgärder från säkerhetskopieringsprogrammet. Överväg BoostFS API-inmatnings- och avslutningsloggar. - Kontrollera värdet som angetts för
OST_ABANDON_TIMEOUT(standard tre timmar). - Kontrollera att RPC-tidsgränsen är större än det värde som angetts för
OST_ABANDON_TIMEOUT.
Ursache
- Problemet beror på en försening i
READochWRITEåtgärder av säkerhetskopieringsprogrammet. Detta utlöser DDFS för att ta bort tidsgränsen. Detta leder till att motsvarande filreferens stängs efter tre timmar (standardvärde) - Det här är standardtidsgränsen för att ignorera som används av DDFS för att identifiera den inaktiva filreferensen. Så småningom kan nya skrivningar uppleva panik på klientsidan.
Lösung
Kontakta Dells support för att öka tidsgränsen som kräver åtkomst till bash.
Ändra OST_ABANDON_TIMEOUT parametern på serversidan med hjälp av stegen nedan. Dess värde kan anges till ett större värde med högst 12 timmar.
Obs! Filsystemet måste inaktiveras och aktiveras som en del av tillämpningen av lösningen.
- Logga in på Data Domain med administratörsbehörighet . Supporten går in i bash-läge och går sedan in i
seläge medddsh -s - Kontrollera originalet
OST_ABANDON_TIMEOUTVärde.
SE@dd## se sysparam show OST_ABANDON_TIMEOUT
- Öka
OST_ABANDON_TIMEOUTVärde. Som standard är värdet 10800 (tre timmar).
SE@dd## se sysparam set OST_ABANDON_TIMEOUT=129600 SE@dd## se sysparam show OST_ABANDON_TIMEOUT Name Description Current Default Override ------------------- --------------------------------- ------- ------- ----- --- OST_ABANDON_TIMEOUT DDCP abandon context timeout(sec) 129600 10800 rpc ------------------- --------------------------------- ------- ------- ----- --- SE@dd##priv set admin
- Starta om filsystemet efter ovanstående parameterändring. Bekräfta med kunden om denna omstart är tillåten. Annars schemalägger du en underhållsperiod för att köra följande kommando:
SE@dd## filesys disable SE@dd## filesys enable
Betroffene Produkte
Data DomainArtikeleigenschaften
Artikelnummer: 000215706
Artikeltyp: Solution
Zuletzt geändert: 14 Jan. 2026
Version: 4
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.