PowerProtect:SQL App Agent 备份失败,并显示ABA0002 “Lockbox contains no entries”

Zusammenfassung: Microsoft SQL Server 数据库备份失败并显示错误 ABA0002,指明在访问密码箱时出错。

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

PowerProtect Data Manager for Microsoft Application Agent 用于保护 Microsoft SQL Server 数据库。Microsoft SQL Server 数据库备份失败并显示ABA0002,指示在访问密码箱时出错。
ABA0002: MY_MSSQL_POLICY: Unable to backup MICROSOFT_SQL_DATABASE asset MY_DATABASE on my-server.my-domain.com to storage target MY_MSSQL_POLICY_STORAGE because of an agent issue.

The protection policy backup was unsuccessful because of an agent issue.

Review the error message for a resolution. If there is no resolution, and the issue persists, contact Dell Customer Support.

Read Less

The protection policy configuration was unsuccessful because the Agent failed with the following error: Error encountered while retrieving information from the lockbox 'C:\Program Files\DPSAPPS\common\lockbox\agents.clb' The Lockbox contains no entries.

Ursache

agent.clb 密码箱信息已损坏。损坏的根本原因尚不清楚。

Lösung

重命名 agent.clb 密码箱文件以重新创建内容。

  1. 对遇到症状的 Microsoft 应用程序代理客户端进行身份验证。
  2. 在 Windows 资源管理器中,浏览到密码箱目录 (C:\Program Files\DPSAPPS\common\lockbox).
  3. 重命名现有的 agents.clb 文件复制到 agents.clb.old.
  4. 重新启动 Dell VM Direct Agent 服务,使用服务控制台 (services.msc)
  5. 启动 Microsoft 应用程序代理 SQL 代理备份以重新创建 agents.clb 密码箱内容。
Artikeleigenschaften
Artikelnummer: 000224362
Artikeltyp: Solution
Zuletzt geändert: 21 Nov. 2025
Version:  2
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.