PowerScale: Tietojen hidas siirto CloudPools-kohteeseen SyncIQ-toimialueen vain luku -polun vuoksi

Zusammenfassung: Tee CloudPools-kohteeseen suuntautuvan hitaan tiedonsiirron vianetsintä tarkistamalla lataustilastot, tarkistamalla käynnissä olevat työt ja muokkaamalla CloudPools-tiedostovarantokäytäntöä ohittamaan vain luku -polut ja varmistamalla, että tiedostoja ei ohiteta vaan ne on lähetettävä pilvikohteeseen. ...

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Tarkista nykyiset lataustilastot.

Tämä toistuu 5 sekunnin välein 60 iteroinnin ajan. Out- ja writes-laskurit kasvavat, mikä osoittaa, että tietoja kirjoitetaan pilvikohteeseen.
# isi statistics cloud list –long –i 5 -r 60
Timestamp    Account  Policy  Cluster-GUID      In  Out  Reads  Writes  Deletions  Cloud  A-Key  P-ID  Node
------------------------------------------------------------------------------------------------------------
1722419028 XXXXXXX                             1.7GB 0.0B   5543       0          0    ECS      5     0     3
1722419028 XXXXXXX                             1.7GB 0.0B   7501       0          0    ECS      5     0     5
1722419028 XXXXXXX                             280.5MB 0.0B    143       0          0    ECS      5     0     1
1722419028 XXXXXXX                             23.6MB 0.0B    111       0          0    ECS      5     0     9
Tarkista käynnissä oleva työ. Katso alla oleva esimerkki.
Clustername-2# isi cloud job v 198
               ID: 198
      Description:
  Effective State: running
             Type: archive
  Operation State: running
        Job State: running
      Create Time: 2024-XX-23T21:37:55
State Change Time: 2024-XX-31T17:50:57
  Completion Time: -
   Job Engine Job: 139852
 Job Engine State: succeeded
      Total Files: 51636073
   Total Canceled: 8821
     Total Failed: 0
    Total Pending: 26476633
     Total Staged: 0
 Total Processing: 148
  Total Succeeded: 25150471

Ursache

CloudPools-tiedostovarantokäytännön peruspolussa on vain luku -muotoisia SyncIQ-polkuja. Koska nämä ovat vain luku -hakemistoja, tiedostoa ei voi korvata tynkä- tai SmartLink-tiedostolla, kuten se on CBM_RESTRICTED_MODIFY Liput.

Lösung

  1. Näytä vain luku -muotoiset SyncIQ-verkkotunnukset luettelolla seuraavalla komennolla:
isi sync target list | grep -i writes_disabled
  1. Muokkaa CloudPools-tiedostovarantokäytäntöä niin, että se ohittaa vain luku -tilassa olevan polun.
isi filepool  pol modify couldpoolpolicyname --begin-filter –path=”existingpath” --and  --path=”readonly_path which needs to be skipped” --operator=ne --end-filter
  1. Tuo CloudPools-tiedostovarantokäytäntö järjestyksen kärkeen käytännön prioriteetissa
  2. Käynnistä CloudPools-työ manuaalisesti määrittämällä polku tai käynnistä SmartPools-työ
isi cloud archive <starting_path> --recursive yes --policy <FP policy name>

Koska polku määritetään manuaalisesti, aloituspolku voidaan määrittää eksplisiittisesti. Polun tarvitaan vain olevan osa polkua, joka on lueteltu tiedostovarantokäytännössä. CloudPools aloittaa polun alla lueteltujen tiedostojen tarkistuksen ja vertaa niitä tiedostovarantokäytäntöön. Vastaavat tiedostot lisätään jonoon, jossa CloudPoolit käsitellään ja arkistointityö luodaan.
 
Huomautus: Vaatimukset, joiden mukaan vain luku -polun alla olevaa tiedostoa ei voi ohittaa, vaan sen on siirryttävä Cloud Targetiin. Poista tällöin SyncIQ-toimialue siten, että tiedostot palautetaan luku/kirjoitustilaan, seuraavalla komennolla:
isi sync target  break   --target-path  SyncIQreadonlypath
Käytännön kohdeyhteyden katkaiseminen johtaa siihen, että kaikki tiedot on synkronoitava täydellisesti seuraavassa synkronoinnissa.
Are you sure? (yes/[no]): Yes

Betroffene Produkte

Isilon, PowerScale OneFS, Isilon SyncIQ
Artikeleigenschaften
Artikelnummer: 000227547
Artikeltyp: Solution
Zuletzt geändert: 05 März 2025
Version:  1
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.