PowerScale. Медленная разгрузка данных в целевое устройство CloudPools из-за пути только для чтения в домене SyncIQ

Zusammenfassung: Устраните проблему низкой скорости выгрузки данных в целевой объект CloudPools, проверив статистику загрузки, проверив выполняемые задания и изменив политику пула файлов CloudPools, чтобы пропускать пути только для чтения, чтобы убедиться, что файлы не пропущены и должны отправляться в целевое облако. ...

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Проверьте текущую статистику загрузки.

Это повторяется каждые 5 секунд в течение 60 итераций. Счетчики «Out» и «Writes» увеличиваются, показывая, что данные записываются в целевое облако.
# isi statistics cloud list –long –i 5 -r 60
Timestamp    Account  Policy  Cluster-GUID      In  Out  Reads  Writes  Deletions  Cloud  A-Key  P-ID  Node
------------------------------------------------------------------------------------------------------------
1722419028 XXXXXXX                             1.7GB 0.0B   5543       0          0    ECS      5     0     3
1722419028 XXXXXXX                             1.7GB 0.0B   7501       0          0    ECS      5     0     5
1722419028 XXXXXXX                             280.5MB 0.0B    143       0          0    ECS      5     0     1
1722419028 XXXXXXX                             23.6MB 0.0B    111       0          0    ECS      5     0     9
Проверьте текущее выполняемое задание. См. пример ниже.
Clustername-2# isi cloud job v 198
               ID: 198
      Description:
  Effective State: running
             Type: archive
  Operation State: running
        Job State: running
      Create Time: 2024-XX-23T21:37:55
State Change Time: 2024-XX-31T17:50:57
  Completion Time: -
   Job Engine Job: 139852
 Job Engine State: succeeded
      Total Files: 51636073
   Total Canceled: 8821
     Total Failed: 0
    Total Pending: 26476633
     Total Staged: 0
 Total Processing: 148
  Total Succeeded: 25150471

Ursache

В базовом пути политик файлового пула CloudPools существуют пути SyncIQ, доступные только для чтения. Поскольку эти каталоги доступны только для чтения, файл нельзя заменить заглушкой или файлом SmartLink, как раньше. CBM_RESTRICTED_MODIFY флагов.

Lösung

  1. Выведите список доменов SyncIQ, доступных только для чтения, с помощью следующей команды:
isi sync target list | grep -i writes_disabled
  1. Измените политику пула файлов CloudPools, чтобы пропустить путь, доступный только для чтения.
isi filepool  pol modify couldpoolpolicyname --begin-filter –path=”existingpath” --and  --path=”readonly_path which needs to be skipped” --operator=ne --end-filter
  1. Переместить политику файловых пулов CloudPools на первое место в приоритете политики
  2. Запустите задание CloudPools вручную, указав путь, или запустите задание SmartPools
isi cloud archive <starting_path> --recursive yes --policy <FP policy name>

Так как путь задается вручную, начальный путь можно указать явным образом. Все, что требуется, — чтобы путь был частью пути, указанного в политике пула файлов. CloudPools инициирует сканирование файлов, перечисленных в пути, и сопоставляет их с политикой пула файлов. Соответствующие файлы добавляются в очередь для обработки CloudPools и создается задание архивирования.
 
Примечание. Существуют требования, согласно которым файл, находящийся по пути только для чтения, нельзя пропустить и он должен быть отправлен в целевое облако. В таких случаях удалите домен SyncIQ, чтобы файлы вернулись в состояние чтения и записи, с помощью следующей команды:
isi sync target  break   --target-path  SyncIQreadonlypath
Нарушение связи с целевым ресурсом политики приводит к тому, что при следующей синхронизации требуется полная синхронизация всех данных.
Are you sure? (yes/[no]): Yes

Betroffene Produkte

Isilon, PowerScale OneFS, Isilon SyncIQ
Artikeleigenschaften
Artikelnummer: 000227547
Artikeltyp: Solution
Zuletzt geändert: 05 März 2025
Version:  1
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.