PowerScale-CloudPools lnn nimeä evästevaraus uudelleen

Zusammenfassung: Solmujen nimeäminen uudelleen aiemmin käytettyjen loogisten solmujen numeroiden (LNN) mukaan voi aiheuttaa evästeavainten varaustiedostojen virheellisen uudelleenkäytön. Tämä voi lisätä riskiä, että useat LIN:t/tiedostot kirjoittavat samoihin pilvidataobjekteihin (CDO). ...

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Tämän ongelman tunnistamiseksi on olemassa useita allekirjoituksia:

idi.log:

IDI_VERIFY=bcm_verify_invalidate_on_valid_storage_layer:577 | COND=BAM Cache Manager invalidate verification | MSG=Cache invalidation is attempted over invalid storage layer: range lbn 512-767 found chunk LBNS: [512,767] snap HEAD revec: [0,0,35184372056064:8192#254 from snap HEAD, (sparse)#2 from snap HEAD ] | LINSNAP= 1:1111:1111

 

Tarkista isi_cpool_d.log seuraavien virheiden varalta:
Alueen virhe:

failed due to error code=12, msg=clapi error: CL_ABORTED_BY_CALLBACK; failed to transfer object range, invalid offset or output stream.

CloudPoolsin eheysvirhe voi ilmetä pilven takaisinkutsun aikana:

CloudPools data integrity error and CL_CHECKSUM_MISMATCH: failed to match the checksum: [error code: CBM_INTEGRITY_FAILURE]

IN /var/log/messages Alla oleva virhe:

Epäonnistunut väite:

isi_cpool_d: *** FAILED ASSERTION res == 0 @ /b/mnt/src/isilon/lib/isi_cpool_cbm2/src/ncoi.c:1025:

Ursache

Tämä on seurausta cpool_fd_store käyttämällä LNN:ää evästeavainten varaustiedostojen tiedostonimissä.

Lösung

Jos CloudPools Klusterilla ei ole koskaan ollut käyttöoikeutta, mutta kuntotarkastus saa alla olevan kriittisen hälytyksen. Sen voi ohittaa:
 

"Your CloudPools are susceptible to data integrity issues. If a PowerScale node's Logical Node Number (LNN) is changed and another node claims the vacated LNN, it could lead to cookie key reservation files being reused incorrectly and can increase the risk of multiple LINs/Files writing to the same Cloud Data Objects(CDOs)."

LNN:n (logical Node Number) uudelleennumerointi voi vaikuttaa CloudPools toiminto, numeroi LNN:t uudelleen oikein suorittamalla alla olevat vaiheet.
Jos haluat numeroida LNN-tunnukset uudelleen, katso: Tietämyskannan 000022252

Jos on aktiivinen CloudPools Klusterissa suoritettava työ, myös seuraavat vaiheet on tehtävä.
*Failing to do so induces the risk of Data Loss.*

 (Tallenna tiedot kaikista tästä tietämyskannan artikkelista suoritettavista komennoista)
 Sitä CloudPools daemon on poistettava käytöstä, LNN on numeroitava uudelleen ja CloudPools-daemon on otettava käyttöön. 

1. Poista käytöstä CloudPools demoni.
   
#isi_for_array isi services -a isi_cpool_d disable
 2. Tarkista isi_cpool_d Daemon on pysäytetty: 
   

  
#isi_for_array ps -lwp `pgrep isi_cpool_d`
3. Numeroi uudelleen lnns:
   
# isi config
>>> lnnset [<old lnn> <new lnn>]
>>> isi_lcd_d restart
>>> commit
>>> exit
4. Poista sekä vanhan että uuden LNN:n olemassa olevat varaustiedostot.

#rm -fv /ifs/.ifsvar/modules/cloud/cookie_res_*_[OLD_LNN]
#rm -fv /ifs/.ifsvar/modules/cloud/cookie_res_*_[NEW_LNN]
#rm -fv /ifs/.ifsvar/modules/cloud/ncoi_key_res_*_[OLD_LNN]
#rm -fv /ifs/.ifsvar/modules/cloud/ncoi_key_res_*_[NEW_LNN]
5. Käynnistä cpool_d demoni.

#isi_for_array isi services -a isi_cpool_d enable

 

Jos LNN-numero on aiemmin numeroitu, suorita seuraavat komennot:
1. Pysäytä CloudPools demoni.
    
#isi_for_array isi services -a isi_cpool_d disable
2. Tarkista isi_cpool_d Daemon on pysäytetty: 
    
#isi_for_array ps -lwp `pgrep isi_cpool_d`
3. Odota 10 sekuntia.
    
#isi_for_array isi services -a isi_cpool_d enable
Jos näin ei tehdä, saatat menettää tietoja. 

  

  

  

  

  

  

  

  

  

  

Weitere Informationen

 

 

Betroffene Produkte

PowerScale

Produkte

Isilon
Artikeleigenschaften
Artikelnummer: 000260843
Artikeltyp: Solution
Zuletzt geändert: 13 Nov. 2025
Version:  9
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.