RecoverPoint: Ausnahme im Server [ java.lang.NullPointerException ] beim Ändern von NTP-Einstellungen in GUI oder CLI

Zusammenfassung: Clients können feststellen, dass NTP-Server unmittelbar nach Codeupgrades auf 4.1.2.x oder 4.3 nicht geändert werden können.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

RP-Upgrade auf 4.1.2.x oder 4.3 von früheren Versionen:

RecoverPoint Splitter: VNX-Splitter
EMC-Software: EMC RecoverPoint 4.1.2.x
EMC-Software: EMC RecoverPoint (RP4VM) 4.3

 

Auswirkungen auf Client: Wenn kein vordefinierter primärer oder sekundärer DNS vorhanden ist, kann die NTP-Server-IP aufgrund einer Nullzeigerausnahme (NPE) nicht geändert werden.

Auswirkungen auf RP: NPE wird von installation_server ausgelöst, wenn versucht wird, die Einstellungen zu ändern.



Symptome gefunden in den Protokollen:

Exception caught in server [java.lang.NullPointerException].

In installation_server Protokollen gibt es (Pathfile: files/home/kos/installationLogs/server.log)

2016-01-11 20:25:59,687 [CommandWorker-6] (Command.java:69) ERROR - Command#run() Throwable. Fehler-UID: 9dda9d2a-9037-405a-bb7f-e01f009baebd java.lang.NullPointerException unter com.kashya.installation.server.commands.global.modify.modifications.DnsModifier.isSiteChanged(DnsModifier.java:10)




Ursache

Im Rahmen der Änderung prüft der installation_server jedes Teil im globalsystemconfig.xml, um festzustellen, ob es geändert wurde. Wenn das DNS überprüft wird, löst es NPE aus, da kein DNS konfiguriert ist. Dies sollte nicht passieren, da der DNS nicht obligatorisch ist.

Lösung

Workaround: Es gibt eine Lösung für dieses Problem,

aber ein Eingreifen von Mitarbeitern des technischen Supports von EMC ist erforderlich. Supportmitarbeiter müssen auf Ihr Speichersystem zugreifen, um dieses Problem zu beheben. Wenden Sie sich an das EMC Customer Support Center oder Ihren Servicemitarbeiter, um technische Unterstützung zu erhalten, und verweisen Sie auf diese EMC Wissensdatenbank-Lösungs-ID.


Lösung:

Dieses Problem wurde in den folgenden RecoverPoint-Versionen behoben: 4.1.SP3, 4.3.SP1 und 4.4.P1
Um festzustellen, ob ein Upgrade für Ihre Umgebung geeignet ist, wenden Sie sich an das EMC Customer Support Center oder Ihren Servicemitarbeiter und verweisen Sie auf diese Lösungs-ID.



Betroffene Produkte

RecoverPoint

Produkte

RecoverPoint
Artikeleigenschaften
Artikelnummer: 000065291
Artikeltyp: Solution
Zuletzt geändert: 04 Aug. 2025
Version:  3
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