PowerScale: Isilon: OneFS: Rask godkjenning med NTLMv2 fungerer ikke.

Zusammenfassung: På Isilon OneFS og PowerScale fungerer ikke Rask godkjenning med NTLMv2. Det fungerer med NTLMv1. Hvis du skal bruke TLS/SSL med NTLM-godkjenning, må alle systemer bruke NTLMv2. NTLMv1 er bare eldre, og bare ren tekst. Swift-implementeringen støtter ikke NTLMv2 for øyeblikket, og vil kreve betydelig rearkitektur for å implementere. Siden tredjeparts Swift-verktøyet som Isilon-komponent er angitt for slutten av levetiden og vil bli fjernet i en fremtidig utgivelse, er det ingen nåværende planer om å redesigne plattformen vår og endre tredjeparts OpenStack Swift-kode for å støtte NTLMv2. Denne artikkelen gjelder for alle versjoner av Isilon OneFS og PowerScale fra og til og med 9.x, og fremover. ...

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Av natur er det ingen praktisk eller praktisk måte å undersøke kryptert (New Technology Lan Manager) NTLMv2-trafikk til/fra godkjenningsleverandøren, for eksempel Active Directory og Isilon. 

Hvis du har en ellers funksjonell Swift-implementering på Isilon som fungerer fint med NTLMv1, vil aktivering og bytting av godkjenningsleverandøren mislykkes, noe som vises på Isilon-siden som passordfeil (LW_ERROR_INVALID_PASSWORD). Det finnes ingen annen praktisk måte å undersøke dette på.

Ursache

Dette skyldes begrensninger i hvordan OpenStack Swift-implementeringen samhandler med Apache og Isilon.

Lösung

Det finnes ingen midlertidig løsning, og ingen forventes å skyldes at Swift har nådd slutten av levetiden på Isilon og PowerScale.

Rask (lwswift) inkompatibel med NTLMv2

Betroffene Produkte

Isilon, Data Migration for Isilon, Isilon Platform API
Artikeleigenschaften
Artikelnummer: 000199438
Artikeltyp: Solution
Zuletzt geändert: 16 Nov. 2023
Version:  3
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.