PowerScale: Isilon: OneFS: A autenticação swift com NTLMv2 não funciona.

Zusammenfassung: No Isilon OneFS e no PowerScale, a autenticação do Swift com NTLMv2 não funciona. Ele funciona com nTLMv1. Para uso de TLS/SSL com autenticação NTLM, qualquer sistema deve usar NTLMv2. NTLMv1 é apenas texto antigo e sem formatação. Atualmente, a implementação do Swift não é compatível com NTLMv2 e exigiria uma rearquitetura substancial para ser implementada. Como o utilitário Swift de terceiros como um componente do Isilon está definido para o fim da vida útil e será removido em uma versão futura, não há planos presentes para reprojetar nossa plataforma e modificar o código OpenStack Swift de terceiros para dar suporte a NTLMv2. Este artigo se aplica a todas as versões do Isilon OneFS e do PowerScale a partir da 9.x e daqui para frente. ...

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Por sua natureza, não há uma maneira prática ou conveniente de examinar o tráfego NTLMv2 criptografado (New Technology Lan Manager) de/para seu provedor de autenticação, como o Active Directory e o Isilon. 

Se você tiver uma implementação do Swift funcional de outra forma no Isilon funcionando bem com o NTLMv1, a ativação e a alternância de seu provedor de autenticação para a execução fora do NTLMv2 falharão, apresentando no Isilon como erros de senha (LW_ERROR_INVALID_PASSWORD). Não há outra maneira prática de examinar isso.

Ursache

Isso se deve às limitações de como a implementação do OpenStack Swift interage com o Apache e o Isilon.

Lösung

Não há uma solução temporária presente e nenhuma é esperada porque o Swift foi alocado como fim da vida útil no Isilon e no PowerScale.

Swift (lwswift) incompatível com NTLMv2

Betroffene Produkte

Isilon, Data Migration for Isilon, Isilon Platform API
Artikeleigenschaften
Artikelnummer: 000199438
Artikeltyp: Solution
Zuletzt geändert: 16 Nov. 2023
Version:  3
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.