PowerStore: Cannot change Language Preference in GUI after Language Pack is installed

Zusammenfassung: The user fails to change Language Preference in PowerStore Manager GUI after a Language Pack is installed.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

After Language Pack is installed, the user tries to change Language to the preference language (for example: Brazilian Portuguese) in GUI, and GUI shows the following errors, and the language is not changed:
Language Preference in PowerStore Manager GUI

This issue affects other languages as well. 

 

Ursache

The PowerStore Manager always detects the preferred language of the browser and uses that locale to load the files translation.json and branding.json. If a Language Pack is not installed, the PowerStore Manager tries to access translation.json and branding.json for that locale. The result is HTTP 404 as expected and the result is cached in CP server. The issue occurs when the CP cache is not cleared after the Language Pack is installed. As a result, after the Language Pack is installed, when the user attempts to change the Language to the preferred language of the browser, GUI still gets HTTP 404 when loading translation.json and branding.json in that locale which prevents GUI from changing the language.

Lösung

If this issue occurs, restart CP in a service container using “svc_container_mgmt” service script.

svc_container_mgmt restart CP  


If the issue still occurs after CP is restarted when changing the language to the preferred language, clear the cache and cookies in the customer’s browser.

Weitere Informationen

For more details on running svc_container_mgmt see Dell EMC PowerStore Service Scripts Guide.

Betroffene Produkte

PowerStore
Artikeleigenschaften
Artikelnummer: 000202758
Artikeltyp: Solution
Zuletzt geändert: 13 Juni 2025
Version:  6
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.