PowerStore: Kieliasetusta ei voi muuttaa graafisessa käyttöliittymässä kielipaketin asentamisen jälkeen
Zusammenfassung: Käyttäjä ei voi muuttaa kieliasetusta PowerStore Manager -käyttöliittymässä, kun kielipaketti on asennettu.
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
Kun kielipaketti on asennettu, käyttäjä yrittää vaihtaa kielen asetuskieleksi (esimerkiksi: Brasilian portugali) graafisessa käyttöliittymässä ja graafisessa käyttöliittymässä näkyy seuraavia virheitä, eikä kieltä muuteta:
Ongelma koskee myös muita kieliä.
Ursache
PowerStore Manager tunnistaa aina selaimen haluaman kielen ja lataa kyseisen kielialueen avulla tiedostot translation.json ja branding.json. Jos kielipakettia ei ole asennettu, PowerStore Manager yrittää käyttää kyseisen paikan translation.json- ja branding.json-tiedostoa. Tulos on odotetusti HTTP 404 ja tulos tallennetaan välimuistiin CP-palvelimeen. Ongelma ilmenee, kun CP-välimuistia ei tyhjennetään kielipaketin asentamisen jälkeen. Kun kielipaketti on asennettu ja käyttäjä yrittää vaihtaa kielen haluamaansa selaimen kieleen, graafinen käyttöliittymä saa tämän vuoksi HTTP 404 -protokollan edelleen ladattaessa translation.json- ja branding.json-muotoja kyseiseen sijaintiin, mikä estää graafista käyttöliittymää vaihtamasta kieltä.
Lösung
Jos tämä ongelma ilmenee, käynnistä CP uudelleen huoltosäilössä huoltokomentosarjalla svc_container_mgmt.
svc_container_mgmt restart CP
Jos ongelma ilmenee edelleen, kun CP on käynnistetty uudelleen, kun vaihdat kielen haluamaksesi, tyhjennä välimuisti ja evästeet asiakkaan selaimessa.
Weitere Informationen
Lisätietoja suorittamisesta on svc_container_mgmtDell EMC PowerStore Service Scripts Guide -oppaassa.
Betroffene Produkte
PowerStoreArtikeleigenschaften
Artikelnummer: 000202758
Artikeltyp: Solution
Zuletzt geändert: 13 Juni 2025
Version: 6
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.