NetWorker: A criação de um novo client não é concluída com a mensagem "is not a valid hostname as it cannot be resolved in DNS"
Zusammenfassung: A adição de um client por meio de Novas propriedades do client no NetWorker 19.7.0.3 não é concluída e relata um erro "Name is not a valid hostname as it cannot be resolved in DNS. Adicione-o ao DNS ou ao arquivo de hosts e faça flush do cache DNS do servidor do NetWorker (dbgcommand -p FlushDnsCache)." ...
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
A adição de um client por meio de Novas propriedades do client no NetWorker 19.7.0.3 não é concluída e exibe o seguinte erro:
Figura 1: Captura de tela da mensagem de erro
Name is not a valid host name as it cannot be resolved in DNS. Please add it to DNS or the hosts file and flush the NetWorker server's DNS cache (dbgcommand -p FlushDnsCache).
Figura 1: Captura de tela da mensagem de erro
Ursache
O hostname falha na resolução de nomes por meio do DNS ou por meio do arquivo "hosts".
Mesmo se o hostname resolver, se essa mensagem de erro tiver ocorrido anteriormente, o cache DNS do NetWorker impedirá que o client seja adicionado.
Lösung
Adicione o hostname do client ao DNS (entradas diretas e inversas) ou adicione-o ao arquivo "hosts" usando o formato:
IP Address [space/tab] FQDN [space/tab] Short Name
Siga as etapas abaixo para "fazer flush" do cache DNS do NetWorker:
- Obtenha o PID dos processos 'nsrd' e 'nsrexecd' usando os comandos abaixo:
Windows:
tasklist | findstr nsrd.exe tasklist | findstr nsrexecd.exe
Linux:
ps -e | grep nsrd ps -e | grep nsrexecd
- Execute o comando abaixo em relação ao PID do "nsrd" e do "nsrexecd" e use o comutador conforme mostrado:
dbgcommand -p FlushDnsCache
Artikeleigenschaften
Artikelnummer: 000212659
Artikeltyp: Solution
Zuletzt geändert: 29 Juni 2023
Version: 3
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.